PDA

View Full Version : Error when running Novashell with Fedora Linux



gaet.morin
07-06-2008, 10:37 AM
I recently download the latest (July 2, 2008) version of Novashell, and I am trying to run it under my Fedora 9 installation.

First, it wouldn't start because it couldn't find /lib/libbz2.so.1.0
I had /lib/libbz2.so.1 and /lib/libbz2.so.1.0.4 installed, so I symlinked /lib/libbz2.so.1.0.4 to /lib/libbz2.so.1.0

Now, when I try to run Novashell it changes my display resolution from 1280x800 to 1024x768 and fails with this error :


X Error of failed request: BadDrawable (invalid Pixmap or Window parameter)
Major opcode of failed request: 143 (XFree86-DRI)
Minor opcode of failed request: 7 ()
Resource id in failed request: 0x3c0000f
Serial number of failed request: 90
Current serial number in output stream: 90

Does anyone know what that means? Does it means Novashell doesn't work with 16:9 resolution? (I don't think so because when I try to change to a 4:3 resolution like 1024x768 it fails with the same error)

Thanks in advance

Seth
07-07-2008, 02:23 AM
Hmm, I really don't know, but you might be the first person to try the linux build since I adjusted the build system. It now doesn't include a lot of libs that used to be statically included. (Like Clanlib for instance)

You're right, it shouldn't have anything to do with aspect ratio of the screen, it supports all screen sizes that the video card supports.

Some random ideas to try:


Does novashell write a log.txt file with any clues?
Is OpenGL installed correctly, do other GL apps run ok?
Try the -window parameter?
Try a full svn checkout and building it yourself?

gaet.morin
07-07-2008, 09:46 AM
When I run novashell with the -window parameter i get the same error (almost) :

X Error of failed request: BadDrawable (invalid Pixmap or Window parameter)
Major opcode of failed request: 143 (XFree86-DRI)
Minor opcode of failed request: 7 ()
Resource id in failed request: 0x400000e
Serial number of failed request: 68
Current serial number in output stream: 68

Here is the log.txt file :

[debug] Setting up joystick
[debug] Joystick Error: /dev/input/js0: No such file or directory
But since I don't have any joystick I don't think this is a problem (or is it?).

Other OpenGL apps run all right (Extreme Tuxracer works, and Compiz works even if I don't use it).

I haven't tried building the svn sources yet but I will.

mikael
07-07-2008, 11:18 AM
It might be direct rendering that isn't on. Could you post the output of the command:
glxinfo | grep direct

gaet.morin
07-07-2008, 11:34 AM
direct rendering: Yes

Well... it looks like it is on

:confused: