PDA

View Full Version : Problem with playing Dink Smallwood



ReiKo
12-24-2009, 05:56 AM
Hello,

I recall playing Dink Smallwood before on 15" monitor and I don't recall two black bars (left and right), but now on same 15" monitor on Windows 7 i don't have fullscreen Dink Smallwood game but 2 black bars on both side of screen.

Is this normal and if it is, how to make Dink Smallwood fullscreen?

Thanks.

Seth
12-24-2009, 06:44 AM
Hmm. The monitor itself may have controls on it that decide whether or not it stretches the image, if it's a wide-screen.

If it isn't a wide-screen I'm not sure why 640X480 full screen would have black bars under the newer OS.

ReiKo
12-24-2009, 07:49 AM
Hmm. The monitor itself may have controls on it that decide whether or not it stretches the image, if it's a wide-screen.

If it isn't a wide-screen I'm not sure why 640X480 full screen would have black bars under the newer OS.

Well, it's on laptop. Dell Inspirion 1545 - 15.6" Widescreen XGA (1366x768) <- Resolution.

ReiKo
12-25-2009, 12:58 PM
And my Dell seems to have widescreen.

Seth
12-27-2009, 04:23 AM
Well, the short answer is the black bars are actually correct, as Dink's aspect ratio is different from your widescreen. Similar to watching an old DVD on your new widescreen, old stuff wasn't design for that wide of a screen.

So while a widescreen is perfect for movies, if you stretch Dink out on it he'll look... fat.

Somewhere hidden away in your desktop display settings there might be a way to set the behavior so you can get "fat dink" if you want.

Might have to ask Dell directly about this. ("How do I control automatic screen stretching when using 640X480 resolution full screen?")

Or maybe someone else here knows where to set this in windows?

ReiKo
12-27-2009, 10:00 PM
Thanks on answering Seth, I really appriciate it.

This is what I got from Dell:




You have to go into the game and adjust the video settings. If it does not list yours select the closest one and that is the best you can get. The issue is with the game not the computer.

Seth, as Dink Smallwood is open source, is there way I can play with it's code and somehow make it stretch to higher resolution or somehow fix the issue that way?

Seth
12-28-2009, 01:08 AM
Basically ALL old games are 4X3 aspect ratio and your wide screen is 16X9, this isn't the fault of the game (other than being old) and generally the video driver or monitor can choose how it wants to stretch or not.

For instance, check this thread (http://www.techsupportforum.com/gaming-forum/pc-gaming-support/112084-stopping-games-stretching-widescreen-monitor.html) to see how an NVidia card can do it:

(in the thread, he is TRYING to get the black bars back and stop the stretching, opposite of what you're doing)

Dink source is available if you want to take a look. Original (http://www.dinknetwork.com/file/dink_smallwood_1_08_source_code/) and FreeDink (http://www.freedink.org/) flavors available.

ReiKo
12-28-2009, 03:05 PM
Thanks,

About source code:

I am proggramer and I was doing some C++ but It was so little and I'm big newbie at it.

Could you suggest me how to and what to do in order to make the game (by modifying the source code) stretch on Widescreen resoultions? Maybe to make Dink Smallwood game for Widescreen resoultions? Guide me to witch part of code should i modify?


btw. Code has problems with compiling under Microsoft Visual Studio 2008?

Thanks.

Seth
01-02-2010, 01:29 AM
Hi. Well, uh, I guess you could setup the code to blit to a temporary 640X480 surface, then stretch it to blit over the full widescreen area.

The code works on Visual Studio 6, for newer versions you have to make some simple changes, the errors should be pretty clear.

ReiKo
01-02-2010, 08:28 AM
Ok, I will try...but I hope someone with much more experience could to the resolution thing.

Thanks.

bjorns87
01-16-2010, 06:56 PM
Hi,

I also had this problem on my notebook.

I think you have an ATI Radeon graphic card?

To solve this problem I downloaded the latest driver software and changed my resoloution to any other than my normal.

1. change the desktop resolution to i.e 800*600 (i.e not the normal u are using)

2. enter ati control center
3.graphics ---> desktop and displays
4. press the arrow on the mini notebook screen inside desktop and displays and press "Configure".
5. Scaling options ---> Change to FULL SCREEN.

6. change back to normal desktop resolution.

works