View Full Version : Editor Scrolling Annoyance

07-11-2010, 03:53 PM
Hey Seth, I have found a minor irritation in the editor that occurs when mouse wheel scrolling in tool windows like the image importer or the layer control inspector, the map also zooms in/out as well.

Obviously one could just use the scroll bar instead but that's no fun. :(

Is there a way to switch wheel zooming off?

07-11-2010, 11:35 PM
In bin/base/script/system/editor.lua comment out the following lines:

GetInputManager:AddBinding("mouse_wheel_up,editor_only", "OnEditorMouseWheelUp", C_ENTITY_NONE);
GetInputManager:AddBinding("mouse_wheel_down,editor_only", "OnEditorMouseWheelDown", C_ENTITY_NONE);

That should disable mouse wheel scrolling. (Untested!)

07-12-2010, 08:23 AM
Works great, thanks.