PDA

View Full Version : Saving Bug



The Humungus
06-17-2012, 04:05 PM
I have been using Novashell without error for a few weeks now, but lately it has been crashing every time I try to save the Main. It usually happens after I start adding images to the Main folder. The exact message I get is "game.exe has stopped working." Any information on how to fix this is appreciated.

Seth
06-17-2012, 10:48 PM
I have been using Novashell without error for a few weeks now, but lately it has been crashing every time I try to save the Main. It usually happens after I start adding images to the Main folder. The exact message I get is "game.exe has stopped working." Any information on how to fix this is appreciated.

Hmm, can you open the editor and try Utilities->Rebuild World Navigation Cache, this will fix things if it's due to corrupted data.

The Humungus
06-18-2012, 12:43 AM
Rebuilding the world navigation cache worked originally, but after adding an additional image to the Main folder more problems were generated. Now, Novashell crashes when I try to restart the engine on the Main, save the Main, or rebuild the world navigation cache.

Seth
06-18-2012, 12:45 AM
Anything about the crash in the log? (log.txt I think?)

If you attach the project I can try running it here, alternatively, (if you're a C++ programmer..) the best way would be to compile a debug version of Novashell with MSVC and run it there, it will show in the source code exactly where the crash is happening.

The Humungus
06-18-2012, 01:44 AM
The log.txt shows nothing, but as I load my project, the console reports these messages:

WorldNavCache Loader: Unable to find tag 553991699. Rebuild maybe?
WorldNavCache Loader: Unable to find tag 1849204817 to link to. Rebuild maybe?
WorldNavCache Loader: Unable to find tag 1849204817. Rebuild maybe?
WorldNavCache Loader: Unable to find tag 553991699 to link to. Rebuild maybe?

Hopefully that sheds some light on the situation...

Also, I am not a C++ programmer, so if the above information does not help, what format does my project need to be in to attach it to a thread? Sorry if I sound terribly incompetent, I am unfamiliar with the upload system on this website.

Thanks for the help so far.

The Humungus
06-18-2012, 04:56 PM
I think I am beginning to understand the problem...

When I turned on my computer this morning and opened my project, it was able to save normally without crashing. Lately, my computer, which runs Vista, was preventing me from changing the names of folders and performing other file managing actions with the same "You do not have permission to change this" message. The only way I had found, so far, to fix this was to restart the computer entirely. However, if the machine ran for a certain amount of time, the message would return. Somehow, I think the computer itself, not Novashell, is generating the problem.

Seth
07-10-2012, 11:32 PM
Hmm. It could be a directory permissions issue, maybe try making a new directory and moving your .novashell file and its directory in there to work from?