Results 1 to 3 of 3

Thread: Problems building clanGUI

  1. #1

    Default Problems building clanGUI

    Hello,
    I had a problem building clanGUI in MSVC6. It returned the following error message

    Compiling...
    precomp.cpp
    C:\Program Files\Microsoft Visual Studio\VC98\INCLUDE\utility(21) : error C2857: '#include' statement specified with the /YcGUI\precomp.h command-line option was not found in the source file
    Error executing cl.exe.

    I am using Clanlib-0.8.0

    Have anyone ever experienced this error before? Any solution?

    Thank you.

  2. #2
    Squire
    Join Date
    Sep 2006
    Location
    Germany
    Posts
    13

    Default

    i didnt' had these problems, but i used it with 0.7.x.
    you should throw this old compiler to the recycle bin.
    use another like MSVC 2005 or msvc2003tk (no download anymore from microsoft) or GCC ( mingw)

  3. #3
    Serf
    Join Date
    Dec 2006
    Location
    Prague, Czech Republic
    Posts
    3

    Default

    Quote Originally Posted by mgarcia View Post
    Hello,
    I had a problem building clanGUI in MSVC6. It returned the following error message

    Compiling...
    precomp.cpp
    C:\Program Files\Microsoft Visual Studio\VC98\INCLUDE\utility(21) : error C2857: '#include' statement specified with the /YcGUI\precomp.h command-line option was not found in the source file
    Error executing cl.exe.

    I am using Clanlib-0.8.0

    Have anyone ever experienced this error before? Any solution?

    Thank you.
    The MSVC6 project for clanGUI has badly configured precompiled headers. Go to Project->Settings... for clanGUI, to the tab C/C++ and choose category "Precompiled Headers" from the combo box. Do this for the entire project (clanGUI) and also for its precomp.cpp file (clanGUI/GUI files/precomp.cpp). Both of these specify a path to a precompiled header and both of these must set it to just precomp.h. However, one of them (can't recall which) has it set to GUI/precomp.h. Change it to just pecomp.h and it will compile fine.

    Don't forget you need to do this both for the Debug and Release configurations.

Similar Threads

  1. Mog freezup problems
    By in forum Dink Smallwood HD
    Replies: 1
    Last Post: 10-05-2004, 07:50 PM
  2. financial problems
    By in forum Dink Smallwood HD
    Replies: 3
    Last Post: 08-13-2004, 07:39 PM
  3. Server problems
    By in forum Funeral Quest
    Replies: 1
    Last Post: 04-07-2004, 07:16 PM
  4. MY Fq server problems...
    By in forum Funeral Quest
    Replies: 29
    Last Post: 09-10-2002, 12:47 AM
  5. fq server problems
    By nieveseri in forum Funeral Quest
    Replies: 2
    Last Post: 08-30-2002, 11:16 PM

Bookmarks

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •