ClanLib 3.0 does require dependencies for Linux. Microsoft Windows does not.

http://clanlib.org/build-environment-linux-gcc.html