Results 1 to 14 of 14

Thread: Error with installing under linux

  1. #1

    Question Error with installing under linux

    I wanted an alternative for Game Maker for windows so i tried this. When i tried to install novashell he give me this error:

    Xlib: extension "GLX" missing on display ":0.0".
    Xlib: extension "GLX" missing on display ":0.0".
    Requested visual not supported by your OpenGL implementation. Falling back on singlebuffered Visual!
    Xlib: extension "GLX" missing on display ":0.0".

    I tried to install it by typing:

    cd /home/****/novashell
    ./novashell

    My distribution is pclinuxos.

  2. #2

    Default

    Sound like the GLX module isn't loaded in your xorg.conf.
    This is what my Module section in xorg.conf looks like:
    Code:
    Section "Module"
    
    
    Load "glx"
    Load "v4l"
    EndSection

    Though I don't think you can simply to add Load “glx” and expect it to work. You'd probably need to install the official linux drivers for your graphics card from it's manufacturer first.
    I don't know how this is done in Pclinux, if there's an automatic installer for closed source drivers or not.
    If you have an Nvidia card there's an installation package for linux you can get from the nvidia website.

    Check the Pclinux documentation on how to get glx working and try running the command “glxgears” which should give you a small window with three spinning 3D gears if it's set up right.

  3. #3

    Default

    Quote Originally Posted by mikael View Post
    Sound like the GLX module isn't loaded in your xorg.conf.
    This is what my Module section in xorg.conf looks like:
    Code:
    Section "Module"
    
    
    Load "glx"
    Load "v4l"
    EndSection

    Though I don't think you can simply to add Load “glx” and expect it to work. You'd probably need to install the official linux drivers for your graphics card from it's manufacturer first.
    I don't know how this is done in Pclinux, if there's an automatic installer for closed source drivers or not.
    If you have an Nvidia card there's an installation package for linux you can get from the nvidia website.

    Check the Pclinux documentation on how to get glx working and try running the command “glxgears” which should give you a small window with three spinning 3D gears if it's set up right.
    If i run glxgears in a console, he says this:

    Xlib: extension "GLX" missing on display ":0.0".
    Error: couldn't get an RGB, Double-buffered visual

    And my xorg.conf section module:

    Section "Module"
    Load "dbe" # Double-Buffering Extension
    Load "v4l" # Video for Linux
    Load "extmod"
    Load "type1"
    Load "freetype"
    Load "/usr/lib/xorg/modules/extensions/nvidia/libglx.so"
    Load "glx" # 3D layer
    EndSection

  4. #4

    Default

    OK, it looks like you have an Nvidia card so make sure that under Section "Device" in xorg.conf there's a line that says Driver "nvidia".

    Also it seems that GLX is loaded twice:
    Load "/usr/lib/xorg/modules/extensions/nvidia/libglx.so"
    Load "glx" # 3D layer

    The first thing to check is if the file libglx.so exists in /usr/lib/xorg/modules/extensions/nvidia/
    also check if libglx.so exists in /usr/lib/xorg/modules/extensions/

    Then try to comment out one of the lines at a time like this:
    Code:
    # Load "/usr/lib/xorg/modules/extensions/nvidia/libglx.so"
    Load "glx" # 3D layer
    Restart X or your entire computer. And if that doesn't work try:
    HTML Code:
    Load "/usr/lib/xorg/modules/extensions/nvidia/libglx.so"
    # Load "glx" # 3D layer
    Again restart X or your entire computer.

    The worst thing that can happen is that X wont start and you have to change xorg.conf back through the command line.

    Also please post what graphics card you have and it would also be helpful if you could post your entire xorg.conf and the file /var/log/Xorg.0.log directly after you've run glxgears.
    Last edited by mikael; 05-08-2008 at 11:03 AM. Reason: Forgot xorg.log

  5. #5

    Default

    Quote Originally Posted by mikael View Post
    OK, it looks like you have an Nvidia card so make sure that under Section "Device" in xorg.conf there's a line that says Driver "nvidia".

    Also it seems that GLX is loaded twice:
    Load "/usr/lib/xorg/modules/extensions/nvidia/libglx.so"
    Load "glx" # 3D layer

    The first thing to check is if the file libglx.so exists in /usr/lib/xorg/modules/extensions/nvidia/
    also check if libglx.so exists in /usr/lib/xorg/modules/extensions/

    Then try to comment out one of the lines at a time like this:
    Code:
    # Load "/usr/lib/xorg/modules/extensions/nvidia/libglx.so"
    Load "glx" # 3D layer
    Restart X or your entire computer. And if that doesn't work try:
    HTML Code:
    Load "/usr/lib/xorg/modules/extensions/nvidia/libglx.so"
    # Load "glx" # 3D layer
    Again restart X or your entire computer.

    The worst thing that can happen is that X wont start and you have to change xorg.conf back through the command line.

    Also please post what graphics card you have and it would also be helpful if you could post your entire xorg.conf and the file /var/log/Xorg.0.log directly after you've run glxgears.
    It worked!! After making a comment of
    Load "/usr/lib/xorg/modules/extensions/nvidia/libglx.so"
    It works.
    Now he says:
    No hardware acceleration available. I hope you got a really fast machine.
    I think i must set the 3d acceleration on, but he says:
    Your system does not support 3D desktop effects
    So i must install a driver, because in a previous version of my linux the 3d effects worked.
    But wich driver??
    And how??? (synaptic???)

    My Xorg.conf file is this:

    # File generated by XFdrake (rev 57713)


    Section "Extensions"
    Option "Composite"
    EndSection

    Section "Monitor"
    Identifier "monitor1"
    VendorName "Plug'n Play"
    ModelName "DELL E773c"
    HorizSync 30.0 - 70.0
    VertRefresh 50.0 - 160.0
    ModeLine "768x576" 50.0 768 832 846 1000 576 590 595 630
    ModeLine "768x576" 63.1 768 800 960 1024 576 578 590 616
    EndSection

    Section "Device"
    Identifier "device1"
    VendorName "nVidia Corporation"
    BoardName "NVIDIA GeForce 3 to GeForce 4 (96xx)"
    Driver "nv"
    Option "DPMS"
    EndSection

    Section "Screen"
    Identifier "screen1"
    Device "device1"
    Monitor "monitor1"
    DefaultColorDepth 24

    Subsection "Display"
    Depth 8
    Modes "1024x768" "832x624" "800x600" "640x480" "480x360" "320x240"
    EndSubsection

    Subsection "Display"
    Depth 15
    Modes "1024x768" "832x624" "800x600" "640x480" "480x360" "320x240"
    EndSubsection

    Subsection "Display"
    Depth 16
    Modes "1024x768" "832x624" "800x600" "640x480" "480x360" "320x240"
    EndSubsection

    Subsection "Display"
    Depth 24
    Modes "1024x768" "832x624" "800x600" "640x480" "480x360" "320x240"
    EndSubsection
    EndSection
    # nvidia-xconfig: X configuration file generated by nvidia-xconfig
    # nvidia-xconfig: version 1.0 (buildmeister@builder3) Mon Apr 16 20:37:13 PDT 2007

    # File generated by XFdrake (rev 57713)
    # ************************************************** ********************
    # Refer to the xorg.conf man page for details about the format of
    # this file.
    # ************************************************** ********************

    Section "ServerLayout"
    Identifier "layout1"
    InputDevice "Keyboard1" "CoreKeyboard"
    InputDevice "Mouse1" "CorePointer"
    Screen "screen1"
    EndSection

    Section "Files"
    # font server independent of the X server to render fonts.
    # minimal fonts to allow X to run without xfs
    FontPath "unix/:-1"
    FontPath "/usr/share/fonts/misc:unscaled"
    EndSection

    Section "Module"
    Load "dbe" # Double-Buffering Extension
    Load "v4l" # Video for Linux
    Load "extmod"
    Load "type1"
    Load "freetype"
    # Load "/usr/lib/xorg/modules/extensions/nvidia/libglx.so"
    Load "glx" # 3D layer
    EndSection

    Section "ServerFlags"
    #DontZap # disable <Crtl><Alt><BS> (server abort)
    #DontZoom # disable <Crtl><Alt><KP_+>/<KP_-> (resolution switching)

    # allows the server to start up even if the mouse does not work
    Option "allowmouseopenfail"
    EndSection

    Section "InputDevice"
    Identifier "Keyboard1"
    Driver "kbd"
    Option "XkbModel" "pc105"
    Option "XkbLayout" "us(alt-intl)"
    Option "XkbOptions" "compose:rwin"
    EndSection

    Section "InputDevice"
    Identifier "Mouse1"
    Driver "mouse"
    Option "Protocol" "ExplorerPS/2"
    Option "Device" "/dev/mouse"
    EndSection
    And after running glxgears there is nothing in the xorg.log

    When i run glxgears i get a full black screen, then i click, and i get a small window with rotating gears. When i terminate (just with the x above, not by direct killing it (ctrl + alt + esc)) glxgears, he says:

    944 frames in 5.1 seconds = 184.588 FPS

    XIO: fatal IO error 11 (Resource temporarily unavailable) on X server ":0.0"
    after 3841 requests (1707 known processed) with 0 events remaining.
    My graphics card is Nvidia GeForce4 MX 440 AGP 8x.
    Last edited by rayman; 05-09-2008 at 10:10 AM.

  6. #6

    Default

    Yes it's most likely a driver issue.
    If you look at your Device section:
    Code:
    Section "Device"
    Identifier "device1"
    VendorName "nVidia Corporation"
    BoardName "NVIDIA GeForce 3 to GeForce 4 (96xx)"
    Driver "nv"
    Option "DPMS"
    EndSection
    It says "Driver "nv"" which is the default open-source Nvidiar driver that is not created by Nvidia and not 3D accelerated.
    If you had the official driver installed it would say:
    Driver "nvidia"

    This link says that the driver package for your card in synaptic is called nvidia_96xx:
    http://pclosmag.com/html/Issues/200803/page04.html

    The strange part is that it almost seems like you've already have the driver installed because it says:
    BoardName "NVIDIA GeForce 3 to GeForce 4 (96xx)"
    And something had added the line:
    Load "/usr/lib/xorg/modules/extensions/nvidia/libglx.so"

    So maybe the driver is already added and all you have to do is change the driver from nv to nvidia?
    Remember though that if you do this and there isn't any nvidia driver X will fail to start.

    Here's another link that says there should be a graphical driver installer in Pclinux 2008 minime.
    I'm not sure if you're using that version but maybe it's the same in yours:
    http://abhay-techzone.blogspot.com/2...pclinuxos.html

    But the easiest thing to do is just to try and start Novashell again and see if it works.
    The GLX problem seems to be fixed and considering that you have 184 FPS in glxgears without 3D acceleration your computer should be fast enough.

  7. #7

    Default

    Quote Originally Posted by mikael View Post
    Yes it's most likely a driver issue.
    If you look at your Device section:
    Code:
    Section "Device"
    Identifier "device1"
    VendorName "nVidia Corporation"
    BoardName "NVIDIA GeForce 3 to GeForce 4 (96xx)"
    Driver "nv"
    Option "DPMS"
    EndSection
    It says "Driver "nv"" which is the default open-source Nvidiar driver that is not created by Nvidia and not 3D accelerated.
    If you had the official driver installed it would say:
    Driver "nvidia"

    This link says that the driver package for your card in synaptic is called nvidia_96xx:
    http://pclosmag.com/html/Issues/200803/page04.html

    The strange part is that it almost seems like you've already have the driver installed because it says:
    BoardName "NVIDIA GeForce 3 to GeForce 4 (96xx)"
    And something had added the line:
    Load "/usr/lib/xorg/modules/extensions/nvidia/libglx.so"

    So maybe the driver is already added and all you have to do is change the driver from nv to nvidia?
    Remember though that if you do this and there isn't any nvidia driver X will fail to start.

    Here's another link that says there should be a graphical driver installer in Pclinux 2008 minime.
    I'm not sure if you're using that version but maybe it's the same in yours:
    http://abhay-techzone.blogspot.com/2...pclinuxos.html

    But the easiest thing to do is just to try and start Novashell again and see if it works.
    The GLX problem seems to be fixed and considering that you have 184 FPS in glxgears without 3D acceleration your computer should be fast enough.
    I had installed it, but it doesn't work. No i gonna try to change it from nv to nvidia.

  8. #8

    Default

    Quote Originally Posted by mikael View Post
    Yes it's most likely a driver issue.
    If you look at your Device section:
    Code:
    Section "Device"
    Identifier "device1"
    VendorName "nVidia Corporation"
    BoardName "NVIDIA GeForce 3 to GeForce 4 (96xx)"
    Driver "nv"
    Option "DPMS"
    EndSection
    It says "Driver "nv"" which is the default open-source Nvidiar driver that is not created by Nvidia and not 3D accelerated.
    If you had the official driver installed it would say:
    Driver "nvidia"

    This link says that the driver package for your card in synaptic is called nvidia_96xx:
    http://pclosmag.com/html/Issues/200803/page04.html

    The strange part is that it almost seems like you've already have the driver installed because it says:
    BoardName "NVIDIA GeForce 3 to GeForce 4 (96xx)"
    And something had added the line:
    Load "/usr/lib/xorg/modules/extensions/nvidia/libglx.so"

    So maybe the driver is already added and all you have to do is change the driver from nv to nvidia?
    Remember though that if you do this and there isn't any nvidia driver X will fail to start.

    Here's another link that says there should be a graphical driver installer in Pclinux 2008 minime.
    I'm not sure if you're using that version but maybe it's the same in yours:
    http://abhay-techzone.blogspot.com/2...pclinuxos.html

    But the easiest thing to do is just to try and start Novashell again and see if it works.
    The GLX problem seems to be fixed and considering that you have 184 FPS in glxgears without 3D acceleration your computer should be fast enough.
    If i start X with the nvidia driver, i get this error:

    EE) NVIDIA(0): ============= WARNING WARNING WARNING WARNING =============
    > (EE) NVIDIA(0): This server has a video driver ABI version of 2.0 but this
    > (EE) NVIDIA(0): driver is designed to work with versions before 2.0.
    > (EE) NVIDIA(0): Please check http://www.nvidia.com/ for driver updates
    > or
    > (EE) NVIDIA(0): downgrade to an X server with a supported driver ABI.
    > (EE) NVIDIA(0): ================================================== =========
    I searched on google.nl for this error, and there they say: You have to start X with the option -ignoreABI. I did that, and X appears, but the mouse stays 10 minutes long a X. Please, is there a linux guru (mikael) who can help me?
    Last edited by rayman; 05-11-2008 at 07:15 AM.

  9. #9

    Default

    Unfortunately closed-source drivers are a constant issue with all Linux distributions.
    I found this page that says you should add -ignoreABI and a couple of other lines in gdm.conf. Though it was written for the Debian distribution it might work for Pclinux:
    http://www.linuxinsight.com/running-...-xorg-7.3.html
    The lines are:
    Code:
    [server-Standard]
    name=Standard Server
    command=/usr/bin/X -audit 0 -ignoreABI
    flexible=true
    If that doesn't work you could try to download the latest 96xx driver directly from Nvidias website:
    http://www.nvidia.com/object/linux_d..._96.43.05.html
    Installation instructions are on the page and seems very simple.
    These drivers are from January of this year and from what I've read this problem started happening to people around October last year, so it's possible that it's fixd in this driver.

    If none of those things work the last thing to try would be to simply change back to the "nv" driver and see if Novashell starts, since you seemingly fixed the GLX error. Though other 3D programs wont work of course

    The very last resort would of course be to try another Linux distribution. You said that 3D effects worked for you on a previous Linux version, so maybe you could switch back to that?
    Otherwise I recommend Ubuntu, but SUSE also looks good, and a tip for when you install is to keep your /home/ directory on a separate partition.
    That way when you have to do a reinstall all you have to do is to format and reinstall / (the root directory) and tell the installation program to use your home partition as /home/ without formatting it. Then all you files and settings are preserved and all you have to do is download the program packages again.

  10. #10

    Default

    Quote Originally Posted by mikael View Post
    Unfortunately closed-source drivers are a constant issue with all Linux distributions.
    I found this page that says you should add -ignoreABI and a couple of other lines in gdm.conf. Though it was written for the Debian distribution it might work for Pclinux:
    http://www.linuxinsight.com/running-...-xorg-7.3.html
    The lines are:
    Code:
    [server-Standard]
    name=Standard Server
    command=/usr/bin/X -audit 0 -ignoreABI
    flexible=true
    If that doesn't work you could try to download the latest 96xx driver directly from Nvidias website:
    http://www.nvidia.com/object/linux_d..._96.43.05.html
    Installation instructions are on the page and seems very simple.
    These drivers are from January of this year and from what I've read this problem started happening to people around October last year, so it's possible that it's fixd in this driver.

    If none of those things work the last thing to try would be to simply change back to the "nv" driver and see if Novashell starts, since you seemingly fixed the GLX error. Though other 3D programs wont work of course

    The very last resort would of course be to try another Linux distribution. You said that 3D effects worked for you on a previous Linux version, so maybe you could switch back to that?
    Otherwise I recommend Ubuntu, but SUSE also looks good, and a tip for when you install is to keep your /home/ directory on a separate partition.
    That way when you have to do a reinstall all you have to do is to format and reinstall / (the root directory) and tell the installation program to use your home partition as /home/ without formatting it. Then all you files and settings are preserved and all you have to do is download the program packages again.
    I installed the nvidia driver from the nvidia page, and... he works!!! I have compiz-fusion running and other 3d programs. Now if i try to start novashell i get no errors and 0.1 second a black screen. Then novashell dont startup. Nothing happens.

  11. #11

    Default

    Try starting Novashell from a command line. When it crashes is anything printed in the command line window?
    Then there's a log file called novashell.log(or something like that) located in the same directory as the novashell executable.
    See if there are any errors reported in it.

    It's also worth checking xorg.0.log again to see if it says anything(it really should contain something).
    Type in the command:
    Code:
    cat /var/log/xorg.0.log
    And see what it outputs.

  12. #12

    Default

    Quote Originally Posted by mikael View Post
    Try starting Novashell from a command line. When it crashes is anything printed in the command line window?
    Then there's a log file called novashell.log(or something like that) located in the same directory as the novashell executable.
    See if there are any errors reported in it.

    It's also worth checking xorg.0.log again to see if it says anything(it really should contain something).
    Type in the command:
    Code:
    cat /var/log/xorg.0.log
    And see what it outputs.

    This stands in ./novashell/log.txt:
    Code:
    [debug] Setting up joystick
    [debug] Joystick Error: /dev/input/js0: No such file or directory
    Error: CL_Error Exception: base/resources.xml: Could not open file: /home/elon/novashell/base/resources.xml
    CL_Error Exception caught : base/resources.xml: Could not open file: /home/elon/novashell/base/resources.xml

  13. #13

    Default

    The errors about not finding any joystick is nothing to worry about. I get them too and they just mean that you don't have a joystick, novashell should still start.

    The problem is that it can't find the file resources.xml:
    Could not open file: /home/elon/novashell/base/resources.xml
    Which is strange since that file should have been placed there when you downloaded and extracted the novashell archive.
    Maybe you didn't extract all files from the novashell_test.tar.gz? Try downloading and extracting Novashell again and see if it works.

    If it still doesn't work run the command:
    Code:
    ls -la /home/elon/novashell/base/
    And copy the output into a forum post.

  14. #14

    Default

    Quote Originally Posted by mikael View Post
    The errors about not finding any joystick is nothing to worry about. I get them too and they just mean that you don't have a joystick, novashell should still start.

    The problem is that it can't find the file resources.xml:
    Could not open file: /home/elon/novashell/base/resources.xml
    Which is strange since that file should have been placed there when you downloaded and extracted the novashell archive.
    Maybe you didn't extract all files from the novashell_test.tar.gz? Try downloading and extracting Novashell again and see if it works.

    If it still doesn't work run the command:
    Code:
    ls -la /home/elon/novashell/base/
    And copy the output into a forum post.
    after re-extracting it works fine!!! thank you.

Similar Threads

  1. Compile Error In Ubuntu Linux
    By Kurisu in forum Official ClanLib SDK Forums
    Replies: 2
    Last Post: 08-18-2008, 05:38 PM
  2. installing clanlib on dev-c++
    By Daunt in forum Official ClanLib SDK Forums
    Replies: 4
    Last Post: 03-03-2008, 11:08 PM
  3. NovaShell in Linux won't start (joystick error)
    By ArmiMaan in forum Novashell Game Creation System
    Replies: 2
    Last Post: 02-18-2008, 12:34 PM
  4. Installing in VS2005
    By mojtaba in forum Official ClanLib SDK Forums
    Replies: 5
    Last Post: 10-26-2007, 02:50 PM
  5. Help! installing ClanLib
    By thfai2000 in forum Official ClanLib SDK Forums
    Replies: 2
    Last Post: 12-21-2006, 09:28 AM

Bookmarks

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •