Results 1 to 4 of 4

Thread: opengl supports ?

  1. #1

    Default opengl supports ?

    when i run GUIBasic.exe (clanlib3.0)

    Name:  opengl_error.png
Views: 69
Size:  41.4 KB

    also computer check by everest, it's show supports opengl3.1(why ? )
    =======================
    OpenGL Compatibility:
    OpenGL 1.1 Yes (100%)
    OpenGL 1.2 Yes (100%)
    OpenGL 1.3 Yes (100%)
    OpenGL 1.4 Yes (100%)
    OpenGL 1.5 Yes (100%)
    OpenGL 2.0 Yes (100%)
    OpenGL 2.1 Yes (100%)
    OpenGL 3.0 Yes (100%)
    OpenGL 3.1 Yes (100%)
    OpenGL 3.2 No (80%)
    OpenGL 3.3 No (80%)
    OpenGL 4.0 NO (15%)
    OpenGL 4.1 No (0%)

    by the way; system: XP sp3; graphy card: Intel(R) HD Graphics (256 MB) and all drive had updated.

  2. #2
    ClanLib Developer
    Join Date
    May 2007
    Posts
    1,824

    Default

    The OpenGL version is reported from "glGetString(GL_VERSION);"

    I don't know what Everest is doing. It seems a bit odd. Unless it is probing the card direct to determine capability

    For OpenGL version 1.1.0 to be reported is usually because the graphic card driver isn't even installed. Hence no graphics acceleration.

  3. #3
    ClanLib Developer
    Join Date
    May 2007
    Posts
    1,824

    Default

    After a quick google. It sems others are having a similar problems (eg https://www.opengl.org/discussion_bo...ension-support )

    Sounds like a buggy driver.

    Maybe go direct to the intel site to locate the driver, instead of the computer manufacturer. ... Hoping that the OEM driver is not locked down

  4. #4

    Default

    Reinstall the driver has no effect, Maybe reinstall the system can.

Bookmarks

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •