Results 1 to 3 of 3

Thread: Clanlib 0.8 or 0.9 for new project

  1. #1
    Lesser Knight
    Join Date
    Aug 2008
    Location
    Folsom, California USA
    Posts
    37

    Default Clanlib 0.8 or 0.9 for new project

    So, if somebody was starting a new project, looking forward to a releasable product perhaps by the end of 2009 or so, should they start development using 0.8.1 or 0.9?

    In other words, is there any hope of a stable Clanlib 0.9 in the next year? I realize there are no guarantees, but the 0.9 API is sufficiently different and has sufficiently compelling features to make it very tempting to take a risk and start using it for early development before it;s completely done, on the hope that it will mature within a year or so

    On the other hand, if the core developers think there's no reasonable chance of 0.9 being stable in 2009...

    Thanks,

    --- Kevin

  2. #2
    ClanLib Developer
    Join Date
    Sep 2006
    Location
    Denmark
    Posts
    554

    Default

    ClanLib 0.9 svn is actually quite stable. More stable than the 0.7.x series ever were, for example.

    The main catch about using 0.9 is that we havn't frozen the API yet, which means we may make some last minute changes to it.

    We were awaiting the release of OpenGL 3.0 to determine what adjustments we needed to make sure our state classes in the clanDisplay abstraction properly matched D3D9, D3D10, OGL2 and OGL3. Since OpenGL 3.0 was recently announced we are currently in the process of making those adjustments (in fact, the current SVN version has most of them already).

    The last two 'major' adjustments we plan for the clanDisplay abstraction is to introduce what I call 'standard shaders' into the API. Those will be used by our 2D rendering routines (CL_Sprite, CL_Draw) and might affect those classes slightly. The other 'major' adjustment planned currently is to change how the message pump is done by clanDisplay (fixing the CL_DisplayMessageQueue API) - a change primarily required by clanGUI to repaint the screen properly.

    After these adjustments we will probably release ClanLib 0.9 as ClanLib 2.0, and rename the 0.8 branch to ClanLib 1.0. We are doing this because the two versions aren't API compatible and we'd like to be able to allow both versions to coexist for those games written with the old API.

  3. #3
    Lesser Knight
    Join Date
    Aug 2008
    Location
    Folsom, California USA
    Posts
    37

    Default

    Thanks for the information. It sounds like 0.9 is definitely the one to use for new development.

    Regards,

    --- Kevin

Similar Threads

  1. Project: Paradigm Game Release 0.1.1
    By DLehr in forum Official ClanLib SDK Forums
    Replies: 6
    Last Post: 06-29-2009, 05:55 AM
  2. Replies: 7
    Last Post: 08-26-2008, 09:57 PM
  3. Is this the right project for ClanLib
    By someone in forum Official ClanLib SDK Forums
    Replies: 1
    Last Post: 08-26-2007, 09:14 PM
  4. "Versionator" pet project
    By Chambers in forum Official ClanLib SDK Forums
    Replies: 0
    Last Post: 07-29-2007, 10:50 PM
  5. when the next project coming out?
    By Wacko Darko in forum RTsoft Tavern
    Replies: 4
    Last Post: 09-09-2004, 08:52 PM

Bookmarks

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •