Results 1 to 2 of 2

Thread: Black screen - no h/w acceleration

  1. #1

    Default Black screen - no h/w acceleration

    I'm trying to run the ClanLib examples on a Linux box with a Matrox card. I've disabled clanGL when building but the examples only show a black window. I get the message

    "No hardware acceleration available. I hope you got a really fast machine.."

    Which is fine, I can happily run with software, but I don't see anything. Any ideas?

    Thanks

  2. #2
    ClanLib Developer
    Join Date
    May 2007
    Posts
    1,824

    Default

    The message "No hardware acceleration available. I hope you got a really fast machine.."
    should only be shown on the ClanGL target.

    It looks like your software driver cannot emulate OpenGL

    The display options with ClanLib 0.8 Linux are OpenGL (ClanGL) and SDL

    As far as I know, the SDL target does not work, as none of the core developers use it. It may be possible for it to be fixed?

    Did you try the Basic2D example using:
    make basic2d_sdl

    SDL support has been removed from ClanLib 0.9 (Unless someone wants to support it)

Similar Threads

  1. Black screen in game
    By Boofo in forum Dungeon Scroll for PC and iPhone
    Replies: 3
    Last Post: 02-02-2013, 10:35 AM
  2. Only a black window...
    By The User in forum Official ClanLib SDK Forums
    Replies: 9
    Last Post: 09-08-2008, 08:05 PM
  3. Font rendering acceleration in v0.9
    By z42 in forum Official ClanLib SDK Forums
    Replies: 3
    Last Post: 02-18-2008, 12:09 PM
  4. No hardware acceleration available.
    By sunnyplain in forum Official ClanLib SDK Forums
    Replies: 1
    Last Post: 01-18-2008, 10:17 AM
  5. OpenGL acceleration
    By IvaN in forum Official ClanLib SDK Forums
    Replies: 1
    Last Post: 02-11-2007, 06:14 AM

Bookmarks

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •