Results 1 to 4 of 4

Thread: execution problem

  1. #1
    Serf
    Join Date
    Feb 2009
    Location
    Brno, Czech Republic
    Posts
    2

    Default execution problem

    hi, i've compiled and made ClanLib without errors. I compiled the first example from INSTALL.linux without problems too.

    [ Makefile ]
    Code:
    PACKAGES = clanCore-0.8 clanDisplay-0.8 clanApp-0.8 clanGL-0.8 clanVorbis-0.8 clanSound-0.8
    CPP = g++ -Wall `pkg-config --cflags $(PACKAGES)`
    lines: 
    	$(CPP) test.cpp -fmessage-length=0 -O3 -o test `pkg-config --libs $(PACKAGES)`
    clean:
    	@rm -f *.o test
    [/ Makefile]

    When i want to run it, it gives my this [even the files from Examples do this]

    "$ ./test: error while loading shared libraries: libclanApp-0.8.so.1: cannot open shared object file: No such file or directory"

    my next step :
    "$ ls /usr/local/lib | grep "clanApp"
    libclanApp-0.8.so.1
    libclanApp-0.8.so.1.0.0
    libclanApp.a
    libclanApp.la
    libclanApp.so
    "
    Please help me.

  2. #2
    Administrator Seth's Avatar
    Join Date
    Jul 2002
    Location
    Japan
    Posts
    5,343

    Default

    Hmm, does doing this fix it?
    Seth A. Robinson
    Robinson Technologies

  3. #3
    Serf
    Join Date
    Feb 2009
    Location
    Brno, Czech Republic
    Posts
    2

    Default

    yes. thx u so much. i rly tried hard, but im linux noob...thx again

  4. #4
    ClanLib Developer
    Join Date
    May 2007
    Posts
    1,824

    Default

    For reference:

    Depending on what distro you are using, sometimes you need to make clanlib as follows:

    ./configure --prefix=/usr
    make
    sudo make install

    <-- Do not do this, if it now works . - Else you will have clanlib installed in 2 difference places, with could cause problems.

Bookmarks

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •