Results 1 to 6 of 6

Thread: font anti alias issue

  1. #1

    Default font anti alias issue

    Hello,

    looks like there is an issue with the 2 and anti alias enabled.

    cu
    Markus

    PS: if there is a bug tracker please tell me...
    Attached Images Attached Images  

  2. #2
    ClanLib Developer
    Join Date
    May 2007
    Posts
    1,824

    Default

    That has been fixed in the latest svn.

  3. #3

    Default

    Quote Originally Posted by rombust View Post
    That has been fixed in the latest svn.
    This fix didn't work for me, for the test I'm using your Font example...
    I'm using the latest Ubuntu Linux, here my steps:

    1. svn up -> revision 2254
    2. autogen.sh -> worked
    3. ./configure --enable-docs --enable-debug -> worked
    4. make -> worked
    5. sudo make install -> worked
    6. sudo ldconfig
    7. change line 68 in Font.cpp to: win_desc.set_size(CL_Size( 1000, 700 ), true);
    8. now the example compiles...
    9. screen shot, still issue with 2 and anti alias on; also the s looks not so good.

    Please tell me if I missed a step, I'm still learning.

    Thanks,
    Markus
    Attached Images Attached Images  

  4. #4
    ClanLib Developer
    Join Date
    May 2007
    Posts
    1,824

    Default

    Sorry, i thought you meant the Vector Font

    hummm, I remember getting the errors you are seeing - Including the "Size 32" button having a line between the 3 and the 2

    I think it was caused by FreeType2, not ClanLib

    Have you updated the FreeType2 library?

    From: http://clanlib.org/docs/clanlib-0.9....linux-gcc.html

    Note: The standard freetype 2.3.7 package that comes with Ubuntu 8.10 (Intrepid Ibex) has very poor quality. It is recommended to reinstall the package from the source code as follows:

    (from: http://download.savannah.gnu.org/releases/freetype/ )
    tar -xvzf freetype-2.3.7.tar.gz
    cd freetype-2.3.7
    ./configure --prefix=/usr
    make
    sudo make install
    I guess the standard package that comes with ubuntu is broken

    Attached is how it looks on my Ubuntu (next to yours) --- Notice it looks a LOT nicer with the updated freetype library
    Attached Images Attached Images  

  5. #5

    Default added bug report in Ubuntu

    https://bugs.launchpad.net/bugs/320301

    I hope it was OK to use your screen shot... if you have anything else to say please add it...

    Thanks,
    Markus

  6. #6
    ClanLib Developer
    Join Date
    May 2007
    Posts
    1,824

    Default

    ... It's now fixed!

    I changed the font hinting to light and it works

    See attached
    Attached Images Attached Images  

Similar Threads

  1. Font Metrics
    By Judas in forum Official ClanLib SDK Forums
    Replies: 1
    Last Post: 08-01-2008, 10:44 PM
  2. Font Problems
    By Vish in forum Official ClanLib SDK Forums
    Replies: 1
    Last Post: 07-26-2008, 07:14 PM
  3. XML Attack State Issue
    By koss911 in forum Novashell Game Creation System
    Replies: 1
    Last Post: 12-11-2007, 10:28 PM
  4. I need help using CL_Font with a System font on the Mac
    By eoliveri in forum Official ClanLib SDK Forums
    Replies: 2
    Last Post: 08-07-2007, 01:59 PM
  5. Latest Beta Bug/Issue
    By SLATE in forum Funeral Quest
    Replies: 5
    Last Post: 09-03-2004, 06:09 AM

Bookmarks

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •