This error occurs when the environment doesn't have automatic SSE2 instruction turned on. There is a simple test for this.

Try and compile the file here.

I found this is to occur specifically in the GDI section. This can be fixed with a simple one line patch to configure.ac.

Code:
Index: configure.ac
===================================================================
--- configure.ac        (revision 3331)
+++ configure.ac        (working copy)
@@ -154,6 +154,7 @@
 fi
 extra_LIBS_clanSDL="-lSDL -lSDL_gfx"
 extra_LIBS_clanRegExp="-lpcre"
+extra_CFLAGS_clanGUI="-msse2"
 
 dnl Store cflags for Setup/pkgconfig/clan*.in pkg-config files
 AC_SUBST(extra_CFLAGS_clanApp)
This should be add with a if statement only for linux. I DO NOT KNOW HOW THIS WILL AFFECT OTHER PLATFORMS. (sorry for the caps).

Also here is my gcc -v
Code:
Using built-in specs.
Target: i486-linux-gnu
Configured with: ../src/configure -v --with-pkgversion='Ubuntu 4.3.3-5ubuntu4' --with-bugurl=file:///usr/share/doc/gcc-4.3/README.Bugs --enable-languages=c,c++,fortran,objc,obj-c++ --prefix=/usr --enable-shared --with-system-zlib --libexecdir=/usr/lib --without-included-gettext --enable-threads=posix --enable-nls --with-gxx-include-dir=/usr/include/c++/4.3 --program-suffix=-4.3 --enable-clocale=gnu --enable-libstdcxx-debug --enable-objc-gc --enable-mpfr --enable-targets=all --with-tune=generic --enable-checking=release --build=i486-linux-gnu --host=i486-linux-gnu --target=i486-linux-gnu
Thread model: posix
gcc version 4.3.3 (Ubuntu 4.3.3-5ubuntu4)