Results 1 to 3 of 3

Thread: clanCore-static-mt-debug.lib

Threaded View

Previous Post Previous Post   Next Post Next Post
  1. #1

    Thumbs up [Resolved]clanCore-static-mt-debug.lib

    So I've tried the things I've seen posted around to resolve this error but I've been unsuccessful.

    Hopefully I'm missing something small, but I will give as much detail as possible to try to avoid extra work for anyone who tries to help me.

    Operating System: Windows 7 x64
    IDE: Visual Studio 2010 Professional

    I followed this tutorial: http://clanlib.org/wiki/MainDocs:Vis...%2B_on_Windows

    I downloaded these binaries and installed them both to C:\ClanLib

    http://clanlib.org/download/binaries...in32-2.2.6.zip
    http://clanlib.org/download/binaries...c-mt-Win32.zip

    (They're both in the same include and lib directory under C:\ClanLib)

    I added the global includes as shown here: http://clanlib.org/wiki/VisualStudio2010GlobalIncludes

    Just verified: Right click application -> Properties -> C/C++ -> General -> Additional Include Directories reads as "C:\ClanLib\lib\Win32;C:\ClanLib\include;%(Additio nalIncludeDirectories)"

    Under Code Generation
    1:
    - Configuration: Active(Debug)
    - Platform: Active (Win32)
    - Runtime Library: Multi-threaded Debug (/MTd)

    2:
    - Configuration: Release
    - Platform: Active (Win32)
    - Runtime Library: Multi-threaded (/MT)


    I've created a basic program from an example:

    Code:
    #include <ClanLib/core.h>
    #include <ClanLib/application.h>
    
    class ConsoleProgram
    {
    public:
       static int main(const std::vector<CL_String> &args)
       {
           CL_SetupCore setup_core;
           CL_ConsoleWindow console_window("Console", 80, 200);
    
           CL_String now = CL_DateTime::get_current_local_time().to_short_datetime_string();
    
           CL_Console::write_line("At %1, we say Hello ClanLib!", now);
           CL_Console::wait_for_key();
    
           return 0;
       }
    };
    
    // Create global application object, you MUST include this line or
    // the application start-up will fail to locate your application object.
    CL_ClanApplication app(&ConsoleProgram::main);
    And I get: "error LNK1104: cannot open file 'clanCore-static-mt-debug.lib'"


    If anyone can see anything I did wrong or has any suggestions, I would appreciate it.
    Last edited by Smitty; 01-18-2011 at 05:59 PM.

Similar Threads

  1. Text Entity for Debug output
    By BigBMan in forum Proton SDK
    Replies: 1
    Last Post: 12-27-2010, 04:27 PM
  2. Annoying debug message.
    By speeder in forum Novashell Game Creation System
    Replies: 0
    Last Post: 04-10-2010, 11:31 PM
  3. Missing "clanCore-static-mtdll-uc-debug.lib"
    By igpay in forum Official ClanLib SDK Forums
    Replies: 3
    Last Post: 04-05-2010, 09:23 PM
  4. how to compile static
    By andreaszdw in forum Official ClanLib SDK Forums
    Replies: 1
    Last Post: 05-07-2007, 05:03 AM
  5. isspace() assert on Debug build
    By Fausto Junior in forum Official ClanLib SDK Forums
    Replies: 0
    Last Post: 12-20-2006, 06:52 PM

Bookmarks

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •