Results 1 to 3 of 3

Thread: Migration from ndk-r4b-crystax and old SDK to latest and crash issue

  1. #1

    Default Migration from ndk-r4b-crystax and old SDK to latest and crash issue

    Hi,
    is there any manual how to migrate from those old components to new? For example to r6b and latest SDK ? I have very starange problems and I think this will resolve them. WHen I start application on device with android 2.1 all is worki on 2.2 and newer I have crash while startup - just after checking SDK version.

    Regards
    -AxeD

  2. #2
    Administrator Seth's Avatar
    Join Date
    Jul 2002
    Location
    Japan
    Posts
    5,340

    Default

    Hmm, I'm trying to remember what I did.. this is from the svn commit:

    * (android) Installed the r15 android sdk and as usual they decided not to remain backwards compatible.. why?!! Rebuilt the build.xml to work with it, this probably means you have to update to the latest android sdk to build for android. Sorry, but blame them!

    BEWARE: From the Google tools r15 docs: "Changed default.properties to project.properties and build.properties to ant.properties. Any existing projects that you build with Ant must be updated with the android update project command."
    I think if you install the latest sdk/ndk, then run "android update project" from the DOS prompt in the /yourapp/android dir it will try to update stuff. But the Build.xml needs changes due to the custom steps I add to find the Proton java source - so you should probably copy that from RTSimpleApp and hand-edit it to change the project name inside.
    Seth A. Robinson
    Robinson Technologies

  3. #3

    Default

    Thank You Seth for hints..... however my problem with Android devices had other source. Project should not be compiled on more than 4 threads in my case and it looks like it has something common with number of hardware cores in CPU.

    Best
    -AxeD

Similar Threads

  1. CL_Integer resources migration to 2.0
    By Shulberry in forum Official ClanLib SDK Forums
    Replies: 0
    Last Post: 07-28-2010, 06:37 PM
  2. ClanGUI in latest 2.2 - new dependency
    By sphair in forum Official ClanLib SDK Forums
    Replies: 1
    Last Post: 05-19-2010, 07:25 AM
  3. Collision bug in latest build
    By whisperstorm in forum Novashell Game Creation System
    Replies: 1
    Last Post: 01-28-2007, 01:29 AM
  4. Latest Beta Bug/Issue
    By SLATE in forum Funeral Quest
    Replies: 5
    Last Post: 09-03-2004, 06:09 AM
  5. were can i download the latest version
    By woody in forum Dink Smallwood HD
    Replies: 1
    Last Post: 06-29-2003, 04:39 PM

Bookmarks

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •