Results 1 to 4 of 4

Thread: Got "unresolved external symbol" in winRTSimpleApp and winRT3DApp When Linking

  1. #1
    Serf
    Join Date
    Feb 2012
    Location
    Hong Kong
    Posts
    2

    Question Got "unresolved external symbol" in winRTSimpleApp and winRT3DApp When Linking

    I'm new to game programming.

    And Barebone compiled successfully on my VS2010.
    But I get
    Code:
    unresolved external symbol "public: __thiscall RenderScissorComponent::RenderScissorComponent(void)"
    While compiling winRTSimpleApp
    and
    Code:
    error LNK2019: unresolved external symbol "public: bool __thiscall RTGLESExt::InitExtensions(void)"
    error LNK2001: unresolved external symbol "class RTGLESExt g_glesExt"
    For RT3DApp.

    Which libraries did I miss, seems they are openGL library symbols. But don't know which ones.~
    Thanks a lot~.

    73

  2. #2
    Administrator Seth's Avatar
    Join Date
    Jul 2002
    Location
    Japan
    Posts
    5,343

    Default

    Oops.

    The problem is I use MSVC2005 mostly and the 2010 projects are not being maintained - most of the examples only have the 2005 version projects. I should make a note of that or delete the 2010 versions probably, as they just cause confusion now.

    To fix the errors in your 2010 project, add these files:

    RTBarebones> shared/Entity/RenderScissorComponent.cpp
    RTSimpleApp> shared/Renderer/RTGLESExt.cpp

    Alternatively, you could try using (importing) the MSVS2005 files instead, and if you have any problems with the setup, look at the existing MSVC2010 project to fix it. I just had to make a small tweak in the binary and debug paths when I imported to make those 2010 versions IIRC.

    For RT3DApp, not sure. Would need to see the error log, everything needed should be included.
    Seth A. Robinson
    Robinson Technologies

  3. #3
    Serf
    Join Date
    Feb 2012
    Location
    Hong Kong
    Posts
    2

    Default

    Thanks a lot~

  4. #4

    Thumbs up Thanks I had the same error for RT3dApp.....

    Well i had the same error thrown for RT3dApp on visual studio 2010 express.......

    It is solved by adding RTGLESExt.cpp to the renderer from shared/Renderer/RTGLESExt.cpp

    Thanks Seth and Victor Zhang

Similar Threads

  1. Unresolved external symbol
    By draculian in forum Official ClanLib SDK Forums
    Replies: 4
    Last Post: 01-10-2011, 08:33 AM
  2. Pilgrimís Quest: Problem in "Welcome to Fire woods!"
    By Floater in forum Dink Smallwood HD
    Replies: 0
    Last Post: 08-18-2009, 06:07 PM
  3. Multiple "keydown" signals on a single keystroke
    By zag in forum Official ClanLib SDK Forums
    Replies: 1
    Last Post: 10-19-2008, 11:04 PM
  4. unresolved external symbol Error
    By Jorda in forum Official ClanLib SDK Forums
    Replies: 1
    Last Post: 02-05-2008, 03:39 AM
  5. Di-Mart Guns -Explanation of the "Store Guy" event
    By rmcnew in forum Funeral Quest
    Replies: 2
    Last Post: 01-15-2004, 06:25 AM

Bookmarks

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •