Results 1 to 5 of 5

Thread: Can't open clanCore-static-mt-debug.lib

  1. #1

    Default Can't open clanCore-static-mt-debug.lib

    Here's the catch:
    I set the project settings to Multi-Threaded Debug, and it's still happening...

    What else could be causing this to happen?

    EDIT: Guess it might be a good idea to point out I'm using VS 2012 and I've built from source.
    Last edited by Bobbias; 02-18-2013 at 09:19 PM.

  2. #2
    ClanLib Developer
    Join Date
    Sep 2006
    Location
    Denmark
    Posts
    554

    Default

    It means the linker cannot find the .lib file you built. You probably need to add the folder where the lib file is to your library search path in Visual Studio.

  3. #3

    Default

    Well, looks like I just forgot the \x64 folder :/

    Now I'm getting "LNK2019: unresolved external symbol _main referenced in function ___tmainCRTStartup"

  4. #4
    ClanLib Developer
    Join Date
    Sep 2006
    Location
    Denmark
    Posts
    554

    Default

    This time the linker cannot find the main() function for the application.

    Console projects need a main() function in Windows, while normal applications need a WinMain() function instead. If you are trying to compile a normal application, then the subsystem setting for the linker is set to the wrong value. Note that the clanApplication library only works for WinMain applications.

  5. #5

    Default

    Ahh, ok, changed from a console application to windows and it works fine. I guess I missed something pointing that out. The program compiles fine now. Thanks for the help, I'm much more used to C#, Java and Python than C++.

    I was trying to compile the Console Hello World sample, so I had made a console app when I created my project.

Similar Threads

  1. Cannot open file: zlib-static-mt-debug.lib
    By Funzo in forum Official ClanLib SDK Forums
    Replies: 7
    Last Post: 02-28-2012, 03:52 PM
  2. Can't find assimp-static-mt-debug.lib
    By crix in forum Official ClanLib SDK Forums
    Replies: 1
    Last Post: 01-03-2012, 02:17 PM
  3. LINK : fatal error LNK1104: cannot open file 'clanCore-static-mt-debug.lib'
    By Chuckleluck in forum Official ClanLib SDK Forums
    Replies: 3
    Last Post: 01-03-2012, 12:06 PM
  4. clanCore-static-mt-debug.lib
    By Smitty in forum Official ClanLib SDK Forums
    Replies: 2
    Last Post: 01-18-2011, 05:59 PM
  5. Missing "clanCore-static-mtdll-uc-debug.lib"
    By igpay in forum Official ClanLib SDK Forums
    Replies: 3
    Last Post: 04-05-2010, 09:23 PM

Bookmarks

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •