PDA

View Full Version : Strange scrolling bug in OSX version:



whisperstorm
03-21-2007, 04:51 PM
This bug is somewhat difficult to describe, however I can describe how to replicate it.

1) launch novashell
2) run top view rpg test
3) click "new"
4) with arrows, run the goblin all the way across the different rooms.

Dont watch the goblin, watch the walls and floor.
What you see is 'smooth scrolling' punctuated by small stutters every second.

If you "go outside" it is more pronounced - watch the trees as you walk by them. It's like "boom boom boom" -- the scrolling is not smooth at all.

It's like the ui is "slipping" every second or so. Does anyone else see this?

I havent tried this on xp yet, but I'll update this if I do.

whisperstorm
03-21-2007, 08:19 PM
I am also seeing this stutter in the treeworld level.

Seth
03-22-2007, 03:29 AM
Hmm, I just tried on my macmini intel and it seems very smooth, no jerks that I can notice.

Are you using a intel or ppc mac? Might be related to that. Also, is the FPS constant?

This may sound weird, but do you have a very, very large monitor connected to your mac?

whisperstorm
03-22-2007, 05:20 AM
It's a powerbook g4 mac laptop. I dont have much else running, but yeah its most likely my machine. It's not a major issue, I'll see if other apps are having scrolling problems.