View Full Version : Can't move forward  :(

06-13-2003, 01:35 PM
hi! I bought TLM yesterday(Order ID: 1055379106-16749-004)

I've played Dink a few years now, so I knew TLM should be a kewl game http://www.rtsoft.com/iB_html/non-cgi/emoticons/smile.gif

but I got a big problem here. I can't move lawn mower forward... http://www.rtsoft.com/iB_html/non-cgi/emoticons/sad.gif Very annoying bug.

when I start new game it just works fine, but after 1 or 2 levels I can't move the machine forward. and in that levels the machine keep going backward from the start(even if I don't touch any directional keys). so I couldn't make it to day 3... Actually unplayable http://www.rtsoft.com/iB_html/non-cgi/emoticons/sad.gif

Can you help me out? I'm using WinME, directx 9.0a, no game pad

06-14-2003, 03:10 AM
Hmm, I had a pretty similar report not long ago:

"Everything seems to work right at the very beginning, But as soon as I go to do my first job, after a little while I start mowing the mower goes "crazy" and I cannot really control it anymore. "

I'm going to check it out and send you anything if I find something, I've never had that happen on this side.

If you save your game, reload TLM and the save game thigns are fixed "for a while"?

Do you use any weird utilities or things that would fool with keyboard input?

Do you have "use gamepad" turned off in the TLM options?

06-14-2003, 06:19 PM
hm.....didn't tried save game.

tried 'game pad on/off'..... got no effect on that bug, and I don't have any app related to keyboard.

I played a few new games today, but didn't encountered same problem. but really weird..... found new bugs(or just features?).

1: got struck by thunder, and my machine flew out of fences,
couldn't get back to inside fences. I just had to go back home

2: sometimes the machine won't mow lawns(maybe cause my machine was damaged? I'm sure I didn't press 's' key...)

I doubt this bugs(including control problem) are somehow
related to rainy days in the game... I'll try again tomorrow

06-14-2003, 11:16 PM
Hm, next time the control problem happens hit Alt-F (I think..) to show the framerate, see if it seems ok.

Lightning being able to knock you out of an area is kind of a design flaw that appeared in the last patch with the improved physics (you can ram an animal and knock him over too), I'm going to fix this in the next patch. It isn't a show stopper but it's slightly unfair.

I'm also going to do a lot of testing under DX9 and recompile with an updated engine, especially checking out the control stuff and possibly updating all sound to FMOD from DirectMusic. (DirectMusic has always seemed a tad buggy)