PDA

View Full Version : Problems with novashell



openformsoft
08-13-2007, 03:10 AM
Hi, I'm fairly new to novashell, but I've been able to follow the tutorials, however, I found several problems with it. For example, I couldnt use the bracket keys [ ], since my keyboard is non-us, and I would like to know how would I have to use them? My keyboard is in spanish, and has the spanish ES layout. Another problem I had was when I tried to specify a 40x40 grid, the dialog box only allowed me to put single digit numbers, from 0 to 9.

Someone know how to correct these problems?

thanks in advanced

Seth
08-16-2007, 11:10 PM
Hmm, can you suggest any other key besides the bracket keys to use for scaling? Also, you can open the properties and type in a scale # directly if need be.

On the grid settings, someone else had this problem, I'm not sure if this is a generic bug with the new clanlib edit box or something region/locale specific yet. Hrm.

0penformsoft
08-17-2007, 03:28 AM
Hi, it's me, hmm, how do i assign another key to novashell? About the grid settings, maybe it's a bug in clanlib, is the other user having that problem from a different region ?

echelonsoftw0rkz
10-12-2007, 11:29 PM
Has anyone looked into this? I just ran into the exact grid problem. Only single digit numbers can be placed. I think it's a bug in clanlib, since my keyboard is US layout.

kououken
08-16-2008, 12:05 PM
Hi y'all. I've had similar keyboard layout problems because I use a Japanese keyboard without a tilde key. (can't access the console)

I solved this in Windows XP by going into Regional settings in control panel, then adding an English-only input method/layout under language settings. You can switch between languages with Alt+Shift or other key combination. This could be irritating if other keys are in different locations as well, but it should at least give you access to all the English keys when you need them.

speeder
03-23-2010, 04:41 AM
Sorry for the Bump... But as you can see, a keyboard customization (even if manually editing XML) would be good, because...

I too have several issues, mostly the Brazillian keyboard looks "almost" like the US, but to support some unique characters (, , , , , ...) some keys are swapped around, including the tilde is swapped for the " key. So when I press " for whatever reason, the console open or closes... (and I have a useless ~ key while using novashell...)

Seth
03-26-2010, 01:53 AM
Ok, will make the `/~ key configurable in the next version.

raulst80
04-22-2010, 09:58 AM
hi, where can i find the tutorials? thank you!

Seth
04-22-2010, 10:07 AM
Tutorials are located here (http://www.rtsoft.com/novashell/docs/).