View Full Version : Bad ELF Interpreter in Fedora 10 KDE

02-11-2009, 09:51 PM
So I decided to try out the Fefora 10 KDE edition, and when attempting to run novashell, I get:

bash: ./novashell: /lib/ld-linux.so.2: bad ELF interpreter: No such file or directory

which perplexes me. :p From what I gather this is the binary executable format for linux, but beyond that, I'm stumped!

02-12-2009, 04:17 AM
Hrm, weird. Maybe try building it from source?

02-13-2009, 04:07 AM
Well KDE 4.1 was much more usable than 4.0, but still not quite there yet for me, so I reinstalled the GNOME edition (Fedora 10). Much to my surprised I'm now getting the same error message I got on KDE. The thing is, the configuration on my current machine is identical to my install before trying KDE... in other words, it must be an issue with the new build of Novashell.

I haven't tried installing from SVN yet because I've had a lot of exams today, etc., but I'll get around to it this weekend.

Sorry if that wasn't very readable, I'm brain dead :eek:

02-13-2009, 09:21 AM
No problem :) Yeah all this linux stuff gives me a headache, I might stop trying to make binaries for it (it seems like an impossible war to win) and just make the svn/build process a little more bullet proof instead.

02-13-2009, 05:37 PM
Yeah, Linux isn't perfect, but at least I know any time I have a problem, there's a 99% chance my dumb ass caused it, and it's fixable, lol. I really don't miss those "mystery bugs" from Windows, or the malware.

02-26-2009, 06:29 PM
Ok, a few days ago I realized something. My new configuration isn't exactly the same. I forgot that this time I installed the 64 bit version. :sweatdrop: So I think the problem is with the ClanLib 64 bit libraries. The 32 bit ones seem to work, as simlinking seems to eliminate the errors, but I still haven't quite gotten it to work yet (school and such....)

tl; dr

Wasn't actually your fault! :p