View Full Version : Problems with the RT3DApp (in iPhone and iPad)

08-02-2011, 02:11 AM
Hello everybody! I'm having some trouble running the example RT3DApp in iPhone/iPad. I am getting the following error:

assert(vSize.x != 0 && vSize.y != 0);

The media folder has been built. Does anybody knows what is the problem?

Thank you!

08-02-2011, 06:09 AM
Hmm, check your output window (I'm assuming you're in debug mode using MSVC) , there may be other warnings before that happens (file not found, etc) that might help us figure it out.

08-02-2011, 02:12 PM
Sorry, i'm using the XCode at Mac OS X Snow Leopard.


08-03-2011, 07:28 AM
media can be built only in windows. If you are using mac how did you built the media? may be that is the reason for crash.

08-03-2011, 01:41 PM
Hello sundar, I will list step by step what i did:

1) I downloaded the svn repository in Mac OS X with svn checkout.
2) i tried to run the RT3DApp xcode project (I recieved errors about missing files: interface, game, audio).
3) I put the files in my external hd
4) In Windows Seven, I run the update_media.bat.
5) In Mac OS X (back) i tried run the xcode project again, then I recieved the assert break :/

Thank you!

08-03-2011, 02:07 PM
Hmm, I don't really have my OSX machine online right now or I'd double check on my end to make sure I didn't break something recently.

Can you post the full log output from xcode?

Maybe try RTBareBones and RTSimpleApp and see if they work ok.