View Full Version : OpenGL error 1281, Missing lost of graphics.

11-22-2011, 11:53 AM

Old Dink player here. Long time I last played the Game though.
See there is a new HD version of the game.
Nice, Thanks.

But ... :-) ... unfortionatly, probably because I have a not to general system/video, I run into a problem.
I'm not seeing 'Dink', and most of the other (none background) game sprites.
In the first game screen the lady that's walking around is for example on showing intermittently. Like popping up from time to time.
(or, like buttons in the minigame/guest start screen. I can hear they are there though. ;-) )

More or less dropping this problem in, in case it might help in a fix ... or if there is any info on what I might try locally to work around this. (with the Dink-HD version and same system/video of course.)

- Forum Search: http://www.rtsoft.com/forums/showthread.php?3670-SetupOrtho-errors (seems related, but no solution.)
- Played around with the in-game graphics setting. (Just in case. End to elimination suggestions in that direction. No effect/change.)
- Lowering the general video Hardware-Acceleration slider did do the trick. At level 1(0[off],1[min/basic]...5[max]) ... although that's not usable for actual game play, just to slow.

Run down of some other collected data.
- Version: Dink Smallwood HD v1.4.7.1
- Error from game log file. (Only error, but lots of them.)
"ERROR: OpenGL error 0x0501 (1281) in Surface::UpdateSurfaceRect line 833"
- System data: [From: Piriform Speccy]
Intel(R) 82915G/GV/910GL Express Chipset Family
Memory 128 MB
Memory type 2
Driver version
MS Windows XP Professional 32-bit SP3

- OpenGL: [From: Log.txt (game)]
GL Version = 1.4.0 - Build
GL Vendor = Intel
GL Renderer = Intel 915G
GL Extensions = GL_ARB_depth_texture GL_ARB_fragment_program GL_ARB_multitexture GL_ARB_point_parameters GL_ARB_shadow GL_ARB_texture_border_clamp GL_ARB_texture_compression GL_ARB_texture_cube_map GL_ARB_texture_env_add GL_ARB_texture_env_combine GL_ARB_texture_env_dot3 GL_ARB_texture_env_crossbar GL_ARB_transpose_matrix GL_ARB_vertex_buffer_object GL_ARB_vertex_program GL_ARB_window_pos GL_EXT_abgr GL_EXT_bgra GL_EXT_blend_color GL_EXT_blend_func_separate GL_EXT_blend_minmax GL_EXT_blend_subtract GL_EXT_clip_volume_hint GL_EXT_compiled_vertex_array GL_EXT_cull_vertex GL_EXT_draw_range_elements GL_EXT_fog_coord GL_EXT_multi_draw_arrays GL_EXT_packed_pixels GL_EXT_rescale_normal GL_EXT_secondary_color GL_EXT_separate_specular_color GL_EXT_shadow_funcs GL_EXT_stencil_two_side GL_EXT_stencil_wrap GL_EXT_texture_compression_s3tc GL_EXT_texture_env_add GL_EXT_texture_env_combine GL_EXT_texture_filter_anisotropic GL_EXT_texture3D GL_3DFX_texture_compression_FXT1 GL_IBM_texture_mirrored_repeat GL_NV_blend_square GL_NV_texgen_reflection GL_SGIS_generate_mipmap GL_WIN_swap_hint

Think that's about it.
... Note: I do have a secondary/backup computer, but have not tried the HD on it yet. ...

11-22-2011, 12:50 PM
Hmm, it looks like your GL Drivers don't like the the parms I'm sending to glTexSubImage2D. I'm afraid they are just too old.. I checked but I didn't see newer drivers anywhere so I'm afraid I don't have a solution.. :(

Your best bet is trying to run the old original version of Dink on that computer, probably.

11-22-2011, 04:04 PM
Yea, I was already afraid that the OpenGL version was just to old.
I know there is one slightly newer driver I have not tried yet (from Intel (using latest HP driver for the system). But I don't expect that to make any difference.

Yea our probably right. Will give the older Dink version a try to.
Thanks for looking at it anyway. :)