View Full Version : Got "unresolved external symbol" in winRTSimpleApp and winRT3DApp When Linking

Victor Zhang
02-03-2012, 02:42 AM
I'm new to game programming.

And Barebone compiled successfully on my VS2010.
But I get

unresolved external symbol "public: __thiscall RenderScissorComponent::RenderScissorComponent(voi d)"
While compiling winRTSimpleApp

error LNK2019: unresolved external symbol "public: bool __thiscall RTGLESExt::InitExtensions(void)"
error LNK2001: unresolved external symbol "class RTGLESExt g_glesExt"
For RT3DApp.

Which libraries did I miss, seems they are openGL library symbols. But don't know which ones.~
Thanks a lot~.


02-03-2012, 02:55 AM

The problem is I use MSVC2005 mostly and the 2010 projects are not being maintained - most of the examples only have the 2005 version projects. I should make a note of that or delete the 2010 versions probably, as they just cause confusion now.

To fix the errors in your 2010 project, add these files:

RTBarebones> shared/Entity/RenderScissorComponent.cpp
RTSimpleApp> shared/Renderer/RTGLESExt.cpp

Alternatively, you could try using (importing) the MSVS2005 files instead, and if you have any problems with the setup, look at the existing MSVC2010 project to fix it. I just had to make a small tweak in the binary and debug paths when I imported to make those 2010 versions IIRC.

For RT3DApp, not sure. Would need to see the error log, everything needed should be included.

Victor Zhang
02-03-2012, 02:59 AM
Thanks a lot~

03-21-2012, 05:40 AM
Well i had the same error thrown for RT3dApp on visual studio 2010 express.......

It is solved by adding RTGLESExt.cpp to the renderer from shared/Renderer/RTGLESExt.cpp

Thanks Seth and Victor Zhang