View Full Version : Problem building xcode project

02-24-2012, 12:42 AM
Hi everyone,
This is my first time posting here. I read about your sdk and it sounds great! I'm really excited to use it. I tried to build the RTBareBones xcode project on the ipad 5.0 simulator but got a few linker errors. They are the following:
Undefined symbols for architecture i386:
"ArcadeInputComponent::ArcadeInputComponent()", referenced from:
App::Update() in App.o
"AddKeyBinding(EntityComponent*, std::string, unsigned int, unsigned int)", referenced from:
App::Update() in App.o
ld: symbol(s) not found for architecture i386
clang: error: linker command failed with exit code 1 (use -v to see invocation)

Is there any solution to this? I suspect it is something in the build settings but am not familiar enough with your sdk to figure it out. Thanks in advance.

02-24-2012, 03:04 AM
Hmm - try opening RTBareBones_xcodev3.xcodeproj instead of RTBareBones.xcodeproj - I should just delete RTBareBones.xcodeproj actually, it's no longer being updated and is now just confusing people. :sweatdrop:

Alternately you could add shared/Entity/ArcadeInputComponent.cpp to the project, this will fix those errors.

02-24-2012, 01:25 PM
Thanks. That fixed the issue with RTBareBones. I added the ArcadeInputComponent file to the RTBareBones.xcodeproj. But I can't find RTBareBones_xcodev3.xcodeproj anywhere in the svn repository or the proton svn I checked out just yesterday. There are other random errors in all the other xcode projects that came with proton. They are all something like this:

CpResource bin/interface /Users/bentrapani/build/Debug-iphonesimulator/RTSimpleApp.app/interface
cd /Users/bentrapani/Documents/RTSimpleApp
setenv PATH "/Developer/Platforms/iPhoneSimulator.platform/Developer/usr/bin:/Developer/usr/bin:/usr/bin:/bin:/usr/sbin:/sbin"
builtin-copy -exclude .DS_Store -exclude CVS -exclude .svn -exclude .git -exclude .hg -resolve-src-symlinks /Users/bentrapani/Documents/RTSimpleApp/bin/interface /Users/bentrapani/build/Debug-iphonesimulator/RTSimpleApp.app
error: /Users/bentrapani/Documents/RTSimpleApp/bin/interface: No such file or directory

I set the generate debug symbols to yes. I made sure that the permissions of the build folder were correct as well. I even tried to manually create the interface file in the RTSimpleApp's bin. None of these things fixed the issue.

02-25-2012, 01:50 AM
Hey Ben,

You're right, RTBareBones_xcodev3.xcodeproj wasn't on svn, my svn checkout of that dir was was corrupted(?) - I've fixed it and just updated RTBareBones.xcodeproj to have the missing file. :excl:

Also, there was a problem with screen init (broke it recently on iOS I guess, oops..) and I was getting only a blank screen in the emulator, fixed that bug on svn as well, if that happened to you.. :sweatdrop:

error: /Users/bentrapani/Documents/RTSimpleApp/bin/interface: No such file or directory

The RTSimpleApp example (and all of them except RTBareBones) requires that the resources be built first - some info here on why (http://www.rtsoft.com/wiki/doku.php?id=proton:win_setup2).. the RTPack util only works on windows and linux currently, maybe the linux build would work for OSX though.. (it's in /tools/RTPack if you want to give it a shot, it's setup for CMake)

02-25-2012, 12:44 PM
Thanks so much! All the problems are fixed:) Now time to learn how to use proton. Your tutorials look great so far.