View Full Version : Ubuntu, ClanGUI, Buttons dont have text

12-31-2013, 11:28 AM
Hello, I have a question:
If i setup a ClanGUI in Linux (i use both ubuntu and xubuntu) and add buttons with some text the text isnt shown. With the same code, however, on windows (on a virtual machine) the text is shown. Am I doing something wrong or do other people have this issue too? I also used google to find something similar but can't find anything. I have this issue since ClanLib 2, not since 3 so back porting to 2 is not a solution.
My Code for setting up Buttons with Text is basically like this:

clan::PushButton button_quit(&window);
button_quit.set_geometry(clan::Rect(clientArea.lef t+5,clientArea.top+230,clan::Size(80,40)));

Like I said: The "Quit" for example is shown on a windows virtual machine but on non of my Linux machines.
I would be very happy to have a solution for it. :)

Edit: Happy New year!

12-31-2013, 05:56 PM
Are you using ClanLib 3.0.1 (Or from GIT since Decemeber 2013) ?

There was a bug in earlier versions, that may cause the error that you see.

Also is the Linux version using GUIThemeAero or GUIThemeBasic or your own one.

Also, what GUI display manager are you using (System/Texture/Direct)?

Also ensure that the examples work

01-02-2014, 10:10 AM
Thank you for your answer.
The examples work with the same bug. I tried it with 3.0.1, will compile it from git now and try it with that one again and edit my post if it works like it should, if i dont it didnt.
The themes didnt make a difference for me, i also tried to change some CSS stuff because i thought that it may be that the font color was the same like for e.g. the button color, which was not the case. (Even tried to change the one to plain white and the other to plain black, no difference).

01-02-2014, 05:23 PM
Perfect, it works with the Git-Version. Thank you very much!
Just out of curiosity, what is the reason for this bug?

01-05-2014, 09:25 AM
No idea!

Looking at the GIT logs since the 3.0.1 release, only Sources\API\GameIDE\FileItemType\file_item_type.h has changed, that has nothing to do with ClanGUI

I guess that you were using 3.0.0