View Full Version : RTPhysics android compile problem

11-19-2012, 08:48 AM
Hi guys, get a problem when compiling RTPhysics android, which has bothered me for a whole day :sweatdrop:

Using latest RTPhysics source with ndk r8 and compile on windows 7 64

click build.bat and after ndk-build, got this error:

.... -Wl,--fix-cortex-a8 -Wl,--no-undefined -Wl,-z,noexecstack -LE:/android-n
dk-r8/platforms/android-8/arch-arm/usr/lib -lGLESv1_CM -ldl -llog -lz -lc -lm -o
obj/local/armeabi-v7a/libRTPhysics.so, ...) failed.
make (e=87):
make: *** [obj/local/armeabi-v7a/libRTPhysics.so] Error 87

Is this due to LOCAL_SRC_FILES in android.mk exceeds windows limitation or anything else?
I could compile and run other android examples successfully in same environment.

Thank you!

11-19-2012, 01:23 PM
Hmm, I tried it on my Win 7-64bit just now and it built and ran without errors. But maybe I have something nonstandard with my shell memory settings..

I went ahead and change it so instead of adding each file, it only uses one ( $(IRRSRC)/UnityBuild_IrrlichtMain.cpp ) so now the Android.mk is a bit smaller. The same could be done for Bullet as well if need be. (A unity build just means a .cpp that includes all the other .cpp files)

So please update svn and try the build again. I also modified the .bat to use 7 threads, faster builds. Really I need to update it to my android v2 build system at some point... I think it's the only example that isn't. Oops, forget to add a comment to my commit. Too late now

11-20-2012, 02:56 AM
Have placed some other cpp files into one file following your way, and now it works! ;)
Maybe later I'll upload my compressed android.mk

Thank you Seth!