View Full Version : 3.0 LegacyGL build errors

03-18-2013, 03:09 PM
Having solved the Sounds/Makefile.in problem, most of the build works but I get the following error:

In file included from opengl_target_provider.cpp:40:0:
GL1/GLX/gl1_window_provider_glx.h:39:35: fatal error: LegacyGL/opengl1_wrap.h: No such file or directory

03-18-2013, 08:39 PM
clanGL1 was shortly renamed to clanLegacyGL, and then afterwards it was moved into clanGL as a sub-target.

Mostly this just means that the old clanGL1 files now belong to clanGL, and that the include paths needs to be updated.

03-18-2013, 11:29 PM
I've tried a strategy of replacing all instances of LegacyGL with GL1, and I added a GL1/precomp.h and GL1/precomp.cpp. For illustration see attached patch. Bear in mind it doesn't include the additions of precomp.h and precomp.cpp, as I don't know that they're actually helpful. I was hoping that various precomp.h might be magical files that would rectify problems on a clean build, but that's not the case. I don't really know or care how gcc utilizes precomp.h files at present, or if it even does. Just hackin'.

I now get definition collisions:

In file included from ./GL1/opengl1.h:35:0,
from ./GL1/opengl1_wrap.h:34,
from GL1/GLX/gl1_window_provider_glx.h:39,
from opengl_target_provider.cpp:40:
./GL1/opengl1_defines.h:68:6: error: multiple definition of 'enum clan::DisplayDefines'
In file included from ../../Sources/API/GL/opengl.h:35:0,
from ../../Sources/API/GL/opengl_wrap.h:35,
from GL3/GLX/gl3_window_provider_glx.h:48,
from opengl_target_provider.cpp:39:
../../Sources/API/GL/opengl_defines.h:84:6: error: previous definition here
This is proving more tedious than the simple "rush to victory" I was hoping for, so assistance in the nature of the collisions would be welcome. I am fearing that the GL1-ification isn't complete, hence the collisions.

03-19-2013, 02:44 PM
Thanks for this patch.

I've fixed the remaining compile and link errors in svn. I haven't actually tried launching any app based on it since the Linux box I got access to only got a SSH console.

03-19-2013, 09:45 PM
It builds! Testing to be done later.