Results 1 to 6 of 6

Thread: Trying to install ClanLib on Ubuntu - zlib vs zlib1g?

  1. #1

    Unhappy Trying to install ClanLib on Ubuntu - zlib vs zlib1g?

    I'm trying to install ClanLib 0.8.0 on Ubuntu linux.

    When I run ./configure, I get this:
    checking for main in -lz... no
    configure: error: " *** ClanLib requires zlib."
    According to Synaptic, I have "zlib1g" and "zlibc" installed. There is no "zlib" in the list to install, although there is "zlib1g-dev" and "zlib-bin", though neither of these look relevant.

    Is "zlib1g" something wholly different than "zlib"? The description in Synaptic leads me to believe it's not. Can anyone tell me what I'm missing or misunderstanding? Maybe it's an Ubuntu quirk?

    Even though I'm a programmer by trade, I'm terrible at sysadmin-type stuff. Thanks for any help you can provide.


  2. #2
    Lesser Knight
    Join Date
    Sep 2006


    I'm guessing its zlib1g-dev that you want, as the dev packages include the headers and library files for development.

  3. #3

    Default "/usr/bin/ld: cannot find -lXmu" during ClanLib installation?

    That was dumb of me. Installed a bunch more packages, and now configure tells me that all packages can be built.

    Now I have a different problem -- "/usr/bin/ld: cannot find -lXmu". Where does Xmu come from? Which package am I missing now?

    The full output of this error follows below. Thanks for your patience and help.

    make[2]: Entering directory `/home/grant/Desktop/ClanLib-0.8.0/Sources/Display'
    /bin/sh ../../libtool --tag=CXX --mode=link g++ -g -O2 -I../../Sources -L/usr/X11R6/lib -o -rpath /usr/local/lib -release 0.8 -version-info 1:0:0 display_target.lo surface.lo canvas.lo color.lo display_iostream.lo display_mode.lo display_window.lo sprite_packer.lo surface_generic.lo setupdisplay.lo sprite.lo graphic_context.lo graphic_context_generic.lo display.lo display_window_description.lo font.lo font_target_sprite.lo keyboard.lo joystick.lo mouse.lo sprite_description.lo input_buffer.lo input_button.lo input_button_generic.lo input_device_generic.lo input_context_generic.lo input_event.lo surface_target.lo display_precomp.lo input_device.lo key_binding.lo resourcedata_collisionoutline.lo resourcedata_font.lo resourcedata_text_styler.lo Providers/jpeg_provider.lo Providers/jpeg_provider_generic.lo Providers/pcx_provider.lo Providers/pcx_provider_generic.lo Providers/png_provider.lo Providers/png_provider_generic.lo Providers/provider_factory.lo Providers/provider_type.lo Providers/targa_provider.lo Providers/targa_provider_generic.lo sprite_packer_generic.lo sprite_generic.lo pixel_format.lo pixel_buffer.lo pixel_buffer_generic.lo pixel_buffer_memory.lo font_generic.lo resourcedata_surface.lo resourcedata_sprite.lo resourcedata_sprite_description.lo input_context.lo display_window_generic.lo glyph_buffer.lo text_styler.lo frameratecounter.lo Collision/collision_outline.lo Collision/collision_outline_generic.lo Collision/outline_math.lo Collision/outline_provider_bitmap.lo Collision/outline_provider_bitmap_generic.lo Collision/outline_provider_file.lo Collision/outline_provider_file_generic.lo -L/usr/X11R6/lib/ -lX11 -lXmu -lGL -lGLU -lpng -ljpeg -lXxf86vm -L/usr/X11R6/lib -lXxf86vm -lz
    g++ -shared -nostdlib /usr/lib/gcc/i486-linux-gnu/4.0.2/../../../../lib/crti.o /usr/lib/gcc/i486-linux-gnu/4.0.2/crtbeginS.o .libs/display_target.o .libs/surface.o .libs/canvas.o .libs/color.o .libs/display_iostream.o .libs/display_mode.o .libs/display_window.o .libs/sprite_packer.o .libs/surface_generic.o .libs/setupdisplay.o .libs/sprite.o .libs/graphic_context.o .libs/graphic_context_generic.o .libs/display.o .libs/display_window_description.o .libs/font.o .libs/font_target_sprite.o .libs/keyboard.o .libs/joystick.o .libs/mouse.o .libs/sprite_description.o .libs/input_buffer.o .libs/input_button.o .libs/input_button_generic.o .libs/input_device_generic.o .libs/input_context_generic.o .libs/input_event.o .libs/surface_target.o .libs/display_precomp.o .libs/input_device.o .libs/key_binding.o .libs/resourcedata_collisionoutline.o .libs/resourcedata_font.o .libs/resourcedata_text_styler.o Providers/.libs/jpeg_provider.o Providers/.libs/jpeg_provider_generic.o Providers/.libs/pcx_provider.o Providers/.libs/pcx_provider_generic.o Providers/.libs/png_provider.o Providers/.libs/png_provider_generic.o Providers/.libs/provider_factory.o Providers/.libs/provider_type.o Providers/.libs/targa_provider.o Providers/.libs/targa_provider_generic.o .libs/sprite_packer_generic.o .libs/sprite_generic.o .libs/pixel_format.o .libs/pixel_buffer.o .libs/pixel_buffer_generic.o .libs/pixel_buffer_memory.o .libs/font_generic.o .libs/resourcedata_surface.o .libs/resourcedata_sprite.o .libs/resourcedata_sprite_description.o .libs/input_context.o .libs/display_window_generic.o .libs/glyph_buffer.o .libs/text_styler.o .libs/frameratecounter.o Collision/.libs/collision_outline.o Collision/.libs/collision_outline_generic.o Collision/.libs/outline_math.o Collision/.libs/outline_provider_bitmap.o Collision/.libs/outline_provider_bitmap_generic.o Collision/.libs/outline_provider_file.o Collision/.libs/outline_provider_file_generic.o -L/usr/X11R6/lib -L/usr/X11R6/lib/ -lX11 -lXmu -lGL -lGLU -lpng /usr/lib/ -lXxf86vm -lz -L/usr/lib/gcc/i486-linux-gnu/4.0.2 -L/usr/lib/gcc/i486-linux-gnu/4.0.2/../../../../lib -L/usr/lib/gcc/i486-linux-gnu/4.0.2/../../.. -L/lib/../lib -L/usr/lib/../lib -lstdc++ -lm -lc -lgcc_s /usr/lib/gcc/i486-linux-gnu/4.0.2/crtendS.o /usr/lib/gcc/i486-linux-gnu/4.0.2/../../../../lib/crtn.o -Wl,-soname -Wl, -o .libs/
    /usr/bin/ld: cannot find -lXmu
    collect2: ld returned 1 exit status
    make[2]: *** [] Error 1
    make[2]: Leaving directory `/home/grant/Desktop/ClanLib-0.8.0/Sources/Display'
    make[1]: *** [all-recursive] Error 1
    make[1]: Leaving directory `/home/grant/Desktop/ClanLib-0.8.0/Sources'
    make: *** [all-recursive] Error 1

  4. #4
    Administrator Seth's Avatar
    Join Date
    Jul 2002


    Hmm, maybe need libxmu-dev?
    Seth A. Robinson
    Robinson Technologies

  5. #5
    Join Date
    Dec 2006


    Quote Originally Posted by Seth View Post
    Hmm, maybe need libxmu-dev?
    Indeed. Worked for me. (Kubuntu 6.06, 64bit). Thanx!

  6. #6


    Another solution that I should have figured out for myself...

    Thanks, guys. I'm now running the Example programs successfully!

Similar Threads

  1. Video in ClanLib
    By d_oilen in forum Official ClanLib SDK Forums
    Replies: 2
    Last Post: 06-04-2007, 02:52 PM
  2. Clanlib physics
    By pTymN in forum Official ClanLib SDK Forums
    Replies: 4
    Last Post: 05-11-2007, 04:19 AM
  3. Help! installing ClanLib
    By thfai2000 in forum Official ClanLib SDK Forums
    Replies: 2
    Last Post: 12-21-2006, 09:28 AM
  4. zlib
    By megumiaraki in forum Official ClanLib SDK Forums
    Replies: 2
    Last Post: 12-07-2006, 07:41 PM
  5. ZX Spectrum Emulator using ClanLib
    By syluridae in forum Official ClanLib SDK Forums
    Replies: 3
    Last Post: 10-31-2006, 06:30 AM



Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts