Results 1 to 2 of 2

Thread: Trouble with CL_InputBox

  1. #1
    Peasant
    Join Date
    Feb 2007
    Posts
    5

    Default Trouble with CL_InputBox

    i use GUI definition file to create inputbox.but can't get the text value.
    Code:
    <inputbox name="input_user1" x="10" y="25" width="134" height="20" text="Silekey" />
    i search code, i think inputbox_generic.cpp:131 may be error:
    Code:
    	slot_set_options = inputbox->sig_set_options().connect(
    		this, &CL_InputBox_Generic::on_set_options);
    	slot_set_options = inputbox->sig_lost_focus().connect(
    		this, &CL_InputBox_Generic::on_lost_focus);

  2. #2
    ClanLib Developer
    Join Date
    Sep 2006
    Location
    Bergen, Norway
    Posts
    588

    Default

    Indeed, this looks like an error. I've commited a fix for this, but I haven't tested if it fixes your error.

Similar Threads

  1. trouble compiling on archlinux
    By god64 in forum Official ClanLib SDK Forums
    Replies: 7
    Last Post: 07-18-2007, 04:28 AM
  2. Trouble with CL_SoundBuffer_Session
    By somar in forum Official ClanLib SDK Forums
    Replies: 0
    Last Post: 06-30-2007, 01:30 PM
  3. having trouble compiling clanlib programs on a mac
    By mike in forum Official ClanLib SDK Forums
    Replies: 4
    Last Post: 06-20-2007, 05:00 PM
  4. Trouble
    By FQ101 in forum Funeral Quest
    Replies: 1
    Last Post: 02-09-2007, 05:05 AM
  5. anyone else having trouble getting
    By jimbobbucky in forum Funeral Quest
    Replies: 4
    Last Post: 07-16-2003, 04:41 AM

Bookmarks

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •