Results 1 to 2 of 2

Thread: Trouble with NetChannel Demo (Port Problem?)

  1. #1

    Default Trouble with NetChannel Demo (Port Problem?)

    I compiled and ran the NetChannel demo that comes with ClanLib 0.8. It works until it gets to the line:


    It never gets farther than this no matter how long I wait. I suspected that this was a port problem, so I opened Windows firewall (I'm using XP), and added this port (TCP and UDP) to the list of exceptions. This did not seem to make any difference.

    This baffled me because I programmed a server and have had several other server applications work on my computer after following that procedure.

    I know it's a problem with my bizarre security settings and not with ClanLib, but I didn't know where else to go with the problem: I'm completely clueless about what to do. Any suggestions or links would be appreciated.

    Edit: It works now, and I have no idea why. Sorry for wasting space.
    Last edited by Wotfreak; 08-12-2007 at 07:40 PM.

  2. #2
    Administrator Seth's Avatar
    Join Date
    Jul 2002


    Hmm, any chance you can try the version of 0.8 that is on SVN? Some fixes have been made since the 0.8 release.

    EDIT: Oops, missed the it works now part.
    Seth A. Robinson
    Robinson Technologies

Similar Threads

  1. demo problem...
    By harrio in forum Novashell Game Creation System
    Replies: 2
    Last Post: 02-25-2007, 11:42 PM
  2. Plans to Port
    By dreamCloud in forum Dungeon Scroll for PC and iPhone
    Replies: 2
    Last Post: 01-04-2007, 02:05 AM
  3. PocketPC port
    By in forum RTsoft Tavern
    Replies: 0
    Last Post: 06-03-2004, 09:54 AM
  4. Hits on http port 80 from FQ?
    By in forum Funeral Quest
    Replies: 5
    Last Post: 08-23-2003, 06:53 AM
  5. Linux port
    By in forum Dink Smallwood HD
    Replies: 2
    Last Post: 09-12-2002, 05:03 AM



Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts