Results 1 to 4 of 4

Thread: Unable to display anything.

  1. #1

    Default Unable to display anything.


    I have a strange problem with the clanLib, everything I want to render is only visible if I run my application in the full screen mode. If not I can only see the white output window.

    Some remarkable about that is that I yesterday installed new video drivers, after that I could until I finally restarted my computer see what I wanted to see.

    Also after some builds and debug sessions the console window that I have created receives no messages, this has worked before as expected.

    Did anyone has the same problem, and maybe solved it?

    Oh here are my relevant system specs:
    Vista Ultimate SP1
    NVIDIA GF 8600 GT (driver version:
    clanLib version: 0.8.1

    This misbehavior also happens at every clanLib example.

    Thanks for every help.

  2. #2
    Master Sorcerer
    Join Date
    Sep 2006


    This is the first time I hear about such a problem in Windows. We have had some minor issues with some Intel drivers for Linux, but nothing so drastic that it only displays a white screen.

    The most likely causes for a white screen sympton would be:

    • OpenGL context creation fails
    • wglSwapBuffers fails
    • The application never calls display.flip() and also never calls CL_System::keep_alive()

    We can rule out the third possibility since you said it also happens with the included examples. I assume you downloaded and installed the official Nvidia drivers from your vendor or from, so that should have installed OpenGL on your system.

    Try download some other OpenGL applications and test if they work on your system - if they do not, then somehow OpenGL has failed to install properly on your system. The OpenGL extension viewer might also be a good idea to try out, since it can tell you what your system supports and maybe reveal a problem.

    Finally you could also try to download ClanLib 0.9 from svn and check if it too fails to initialize OpenGL on your computer.

  3. #3



    thanks for the answer. But i think I have found a solution for the problem (with an overall performance boost for my system ).

    As I use Vista i tried to change my design from "Windows Vista" to "Windows - classic", now I can see everything I want to display, all examples are working now too. Including this and the performance gain on vista its not that bad for a simple "bug fix".

    At my company computer which also uses Vista my application worked very well, with enabled Vista Aero design. I wonder whats the difference, except that I use at my company some ATI graphic card.

    I also tried the OpenGL extension viewer viewer, here are some small results from the rendering tests:

    Vista Aero design:
    windowed - i could see through the window, nothing was rendered
    full screen - everything looked ok

    No Vista Aero design:
    windowed - everything looked ok
    full screen - everything looked ok

    Maybe I should track down the problem, but now it works and IŽam happy with it.

    mfg Mark

  4. #4
    ClanLib Developer
    Join Date
    May 2007


    I tried ClanLib 0.8 on Vista using both Vista Aero and Classic, and both work on my nvidia card (NVIDIA Quadro FX 3400 / 4400)

    Maybe it is a graphic card driver problem.

Similar Threads

  1. 'Unable to locate worlds' error
    By Ketla in forum Novashell Game Creation System
    Replies: 2
    Last Post: 04-12-2008, 02:10 PM
  2. problem with CL_Surface display a PNG
    By lurker2000wxc in forum Official ClanLib SDK Forums
    Replies: 3
    Last Post: 03-14-2008, 09:18 AM
  3. Display targets and input
    By void_kill in forum Official ClanLib SDK Forums
    Replies: 0
    Last Post: 03-23-2007, 11:56 PM
  4. I Am Unable to Download Dink
    By Skyehawk in forum Dink Smallwood HD
    Replies: 3
    Last Post: 02-16-2007, 12:46 AM
  5. Clanlibs display errors
    By megumiaraki in forum Official ClanLib SDK Forums
    Replies: 0
    Last Post: 12-07-2006, 07:20 AM



Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts