Results 1 to 5 of 5

Thread: VC2005 "debugging information corrupt"

  1. #1

    Default VC2005 "debugging information corrupt"

    I've followed the guides on the website for setting up clib on VC2005(pro), and i'm trying to compile the hello world sample using the precompiled binaries. I get the following error:

    clanCore-static-mt-debug.lib(console_window.obj) : fatal error LNK1103: debugging information corrupt; recompile module
    I've tried switching between debug and release but i still get the same error. Am i missing something here or are the current binaries corrupt? I've tried redownloading them without luck.

    Any help would be highly appreciated

  2. #2
    ClanLib Developer
    Join Date
    Sep 2006
    Bergen, Norway


    Dunno if 2008 binaries are compatible with 2005... that might be a cause. Would suggest compiling ClanLib yourself.

  3. #3
    ClanLib Developer
    Join Date
    May 2007


    It looks like the precompiled libraries are not backward compatible - I thought they were?

    A few things to try
    1) Ensure you are running SP1 for VS 2005 ( "Microsoft® Visual Studio® 2005 Team Suite Service Pack 1" )
    2) Download Visual Studio 2008 Express Edition
    3) Download an compile the complete source

  4. #4


    Yep, compiling it myself solved it. Wasn't nearly as hard as i feared

    Then all the other libs gave me the same error. Thankfully i found a set of 2005 libs so it's all good now!

    Someone should correct the website so it doesn't say "precompiled binaries for Visual C++ 2005 and 2008", since the stuff that's linked doesn't work for 2005.

    Thanks for the help guys!

  5. #5
    ClanLib Developer
    Join Date
    May 2007


    Strange though, I used the precompiled external libs for visual studio 2002, and they worked. (i've upgraded now)

    Note, for other people having the same problems:

    See - for the external libs source code packages

    Edit (in notepad) the .vcproj, and change [Version="9.00"] to [Version="7.00"] - This seems to work

Similar Threads

  1. Pilgrim’s Quest: Problem in "Welcome to Fire woods!"
    By Floater in forum Dink Smallwood HD
    Replies: 0
    Last Post: 08-18-2009, 06:07 PM
  2. Questin about "Tests : window1 project"
    By Eng C. Born in forum Official ClanLib SDK Forums
    Replies: 6
    Last Post: 05-12-2009, 06:46 PM
  3. Multiple "keydown" signals on a single keystroke
    By zag in forum Official ClanLib SDK Forums
    Replies: 1
    Last Post: 10-19-2008, 11:04 PM
  4. Coppying "skeleton" wont work (MAC)
    By Suudsu2200 in forum Novashell Game Creation System
    Replies: 1
    Last Post: 03-04-2007, 08:24 PM
  5. Di-Mart Guns -Explanation of the "Store Guy" event
    By rmcnew in forum Funeral Quest
    Replies: 2
    Last Post: 01-15-2004, 06:25 AM



Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts