Results 1 to 5 of 5

Thread: CL2.1.0 display problems

  1. #1

    Default CL2.1.0 display problems


    I'm having some display related problems with Clanlib 2.1.0.

    In Windows Vista/Visual Studio 2008 Pro, some of the images are not drawn correctly on screen: for example when shooting in SpritesRTS a small white box appears on top of the tank and after that no missile is shown. I got similar behaviour when drawing multiple CL_Images loaded from a .png-file on a window: the first CL_Image::draw works correctly but the following images are shown as a white rectangle equal to the size of the image.

    I worked around the problem using CL_PixelBuffers and gc.draw_pixels instead which at first seemed to do the trick, but then had issues using and drawing CollisionOutlines - looking at the object behaviour they seem misplaced and I can't get them to show at all on screen.

    I thought the problem might be Windows related, so I tried installing Clanlib/Ubuntu 9.10, but with no results: in Ubuntu for instance the Pacman example draws only the text on screen, leaving everything else black.

    My graphics card is ATI Mobility Radeon HD2600, the drivers and catalyst are up to date. I'm using DirectX SDK version August 2009. There's no compiling errors at all, only occasionally some warnings about uncasted floats.

  2. #2
    ClanLib Developer
    Join Date
    May 2007


    Try the GL1 target and the GDI target (See the basic2d example for more info)

    For some reason, the GLSL shader is not using multiple textures on your card.

    If so, the GL1 target (OpenGL 1.3) should work.

    That should help pinpoint the problem

  3. #3


    Thanks a lot, using the GDI target seems to work. Can't locate 'gl1.h' needed in order to use GL1 though, despite I followed the documented installation procedure.

  4. #4


    Actually, the SpritesRTS example does some strange stuff with the GDI target, such as not showing the tanks at all in the beginning. Selecting their area makes them visible for a moment but after that their parts appear and disappear pretty randomly. Seems that GL1 is not part of the configure wizard ClanLib.svn file, can it be compiled manually?

  5. #5
    ClanLib Developer
    Join Date
    May 2007


    The GDI target uses ClanLib's software renderer. SpriteRTS uses some advanced blending (if I remember correctly), that GDI does not currently support.

    Anyway, the GL1 target needs enabled in configure.exe ... There is a Checkbox to enable it "Include OpenGL 1.x target". See attached.

    (I thought that it was automatically enabled. I guess, it's not!)
    Attached Images Attached Images  

Similar Threads

  1. GUI / Rendering Display
    By Fr3DBr in forum Official ClanLib SDK Forums
    Replies: 4
    Last Post: 08-22-2009, 11:00 PM
  2. clanGDI display bug in linux
    By MedO in forum Official ClanLib SDK Forums
    Replies: 3
    Last Post: 05-01-2009, 01:12 PM
  3. Unable to display anything.
    By Dermark in forum Official ClanLib SDK Forums
    Replies: 3
    Last Post: 06-11-2008, 01:08 PM
  4. problem with CL_Surface display a PNG
    By lurker2000wxc in forum Official ClanLib SDK Forums
    Replies: 3
    Last Post: 03-14-2008, 09:18 AM
  5. Clanlibs display errors
    By megumiaraki in forum Official ClanLib SDK Forums
    Replies: 0
    Last Post: 12-07-2006, 07:20 AM



Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts