Results 1 to 3 of 3

Thread: OSX 10.5 problems

  1. #1
    Join Date
    Jan 2011

    Default OSX 10.5 problems


    Today I've tried to run BareBones example on my Mac with OSX 10.5.8 but I had 2 compilation errors in MyOpenGLView.h:

    /Users/marcinp/Desktop/ProtonSDK/RTBareBones/OSX/../../shared/OSX/app/MyOpenGLView.h:10:33: error: AppKit/NSOpenGLLayer.h: No such file or directory
    /Users/marcinp/Desktop/ProtonSDK/RTBareBones/OSX/../../shared/OSX/app/MyOpenGLView.h:15: error: cannot find protocol declaration for 'NSApplicationDelegate'
    This is because both AppKit/NSOpenGLLayer and NSApplicationDelegate are new in OSX 10.6 and are not supported by previous versions.

    I looked into the code and found out that NSOpenGLLayer is never used so I removed the #import line. I also found on some forums that I can remove <NSApplicationDelegate> from:
    @interface MyOpenGLView : NSView<NSApplicationDelegate>
    After these changes project was compilied and linked properly. Unfortunately when I try to run it, it ended with:

    Program received signal:  “SIGABRT”.
    Here is the callstack:
    #0	0x956ede42 in __kill
    #1	0x956ede34 in kill$UNIX2003
    #2	0x9576023a in raise
    #3	0x9576c679 in abort
    #4	0x9522308c in _RegisterApplication
    #5	0x952225ea in GetCurrentProcess
    #6	0x917f7138 in GetSystemUIMode
    #7	0x917f70e7 in IsMenuBarVisible
    #8	0x92366419 in _NSInitializeAppContext
    #9	0x92365da0 in -[NSApplication init]
    #10	0x923657b1 in +[NSApplication sharedApplication]
    #11	0x92369100 in NSApplicationMain
    #12	0x000901dc in main at main.m:5
    Could you help me solving this problem? It's really important for me to run my application on OSX 10.5 (or even 10.4).

    BTW Did anybody tried to build any Proton application on OSX 10.6 and run it on older version?

    Thanks in advance

  2. #2
    Administrator Seth's Avatar
    Join Date
    Jul 2002


    Hmm, I don't have an answer, but this gives me a solid reason to update to Lion on one of my mac boxes sooner rather than later. (So I can work it out)

    Or, if someone else has, please submit a patch..
    Seth A. Robinson
    Robinson Technologies

  3. #3
    Join Date
    Sep 2011


    Hi, sorry for bumping, but I have a possible explanation and I found this thread after googling for this problem, which is propably totally unrelated to the stuff you are doing here. (read: I have no clue what Proton SDK is) So maybe it will help others searching for the same problem.

    The mentioned behaviour by the thread starter is propably due to a misconfigured Info.plist file. When the application is launched via the Finder, it would propably tell that the minimum required OS version is higher than the current one. Not so for the Xcode debugging, which will just kill the application at the first location the NSApplication object is instanciated.

    The following entry could be responsible:

    Info.plist excerpt:
    <plist version="1.0">
    If this entry is removed the application should be running again properly.

    (Just to be more complete: of course, if there is some 10.6.6 SDK dependency apart from the entry in the plist, it should not compile in the first place. However, if there are just some Objective-C member functions called, XCode may just issue a warning, but die at runtime. See also Objective-C class selectors and "weak linking")



Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts