Results 1 to 6 of 6

Thread: crash on startup, android

  1. #1
    Lesser Knight
    Join Date
    Jul 2011
    Posts
    51

    Default crash on startup, android

    my app and all the proton examples crash on startup for some reason, both in the emulator and my phone.
    I'm using the latest sdk r16 and ndk r7, and newest proton source.

    Tried debugging with ndk-gdb, it gives me this single line when the apps crash
    Program terminated with signal SIGSEGV, Segmentation fault.
    Any ideas???
    Last edited by darkchazz; 12-28-2011 at 07:00 PM.

  2. #2
    Administrator Seth's Avatar
    Join Date
    Jul 2002
    Location
    Japan
    Posts
    5,375

    Default

    Weird. I'm still using NDK r6, might try that? I think r7 adds a new toolchain setup so we don't need cygwin anymore, I plan to play with that at some point.

    Also, do a full rebuild if you haven't, if headers change it isn't smart enough to figure out what needs to be rebuilt properly.
    Seth A. Robinson
    Robinson Technologies

  3. #3
    Lesser Knight
    Join Date
    Jul 2011
    Posts
    51

    Default

    r6 and a full rebuild did not solve the problem
    Tried both 64bit and 32bit JDK , no difference..

    It must be something I did since it was working fine before I did the format and reinstalled everything on my new SSD...

    sdk r16, ndk r7, ant 1.8.2, JDK 6 Update 30

    Loaded sdk packages:
    sdk tools + platform tools
    android 4.0.3 + 2.3.3 + 2.2 (platform and google APIs)
    google market licensing + USB driver packages

    Added environment vars:
    ANT_HOME C:\Android\apache-ant-1.8.2
    CYGWIN_DIR C:\cygwin
    JAVA_HOME C:\Program Files (x86)\Java\jdk1.6.0_30
    Path C:\Android\android-sdk\platform-tools;C:\Android\android-sdk\tools;C:\Android\apache-ant-1.8.2\bin;C:\Android\android-ndk-r7

    What android sdk version are you using ???
    Last edited by darkchazz; 12-28-2011 at 07:15 PM.

  4. #4
    Administrator Seth's Avatar
    Join Date
    Jul 2002
    Location
    Japan
    Posts
    5,375

    Default

    I think I am using SDK r15 with ndk r6.

    The only tips I can think of:

    To debug your problem I'd stick with RTBareBones (the simplest), and in android/jni/Application.mk, change APP_OPTIM=release to APP_OPTIM=debug if you didn't already, gdb might give better info.

    Also, run ViewLogDefaultPhone.bat (or the one for the emulator) and watch that log closely, may be some clue there.

    If that fails, I'd step back and try to compile some examples the NDK comes with (not using Proton) to just make sure everything is kosher there.
    Seth A. Robinson
    Robinson Technologies

  5. #5
    Lesser Knight
    Join Date
    Jul 2011
    Posts
    51

    Default

    Will do and report back later.

    EDIT:
    Ok, now I feel like an idiot xD
    Turns out it was crashing because I forgot to generate the rttex files, so build.bat did not copy anything and the apk was empty, and crashes on startup because it couldn't find the background image file...
    Can't believe I had to debug to find that out

    I noticed though that compiling for armeabi-v7a gives a nice speed boost to the irrlicht collision detector, the frame rate in the quake map is constant 60fps and never drops at all, whereas with armeabi it drops to the 30s a lot especially when running into a wall or going up the stairs...
    Last edited by darkchazz; 01-01-2012 at 10:24 PM.

  6. #6
    Serf
    Join Date
    Jan 2012
    Location
    El Paso, TX
    Posts
    1

    Default Crash

    Thanks for this topic darkchazz. I have experienced the same problem. A bit frustrating but, I need to find a solution for it. Luckily, I saw this topic. I will continue watch this thread and will contribute whenever I resolved it.

Similar Threads

  1. Crash this bug
    By huntercool in forum Official ClanLib SDK Forums
    Replies: 2
    Last Post: 09-29-2009, 02:40 PM
  2. Crash on startup under Ubuntu 7.04
    By Rrrichi in forum Novashell Game Creation System
    Replies: 5
    Last Post: 06-08-2007, 11:28 AM
  3. nosound crash at startup
    By sphair in forum Novashell Game Creation System
    Replies: 1
    Last Post: 02-07-2007, 07:04 AM
  4. Error at startup
    By in forum Other RTsoft Games
    Replies: 3
    Last Post: 06-28-2006, 09:27 AM
  5. Help on startup?
    By in forum Other RTsoft Games
    Replies: 2
    Last Post: 06-28-2005, 05:18 PM

Bookmarks

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •