Results 1 to 4 of 4

Thread: MVSE2013: stumble with d3d11_createdeviceandswapchain()

  1. #1

    Default MVSE2013: stumble with d3d11_createdeviceandswapchain()


    My problem is not quite in clanlib, but who can faced, please help)

    I've notebook (celeron) with Windows 7, Microsoft visual studio express 2013, ClanLib-3.0.1.

    When i run blend example with debug (by pressing F5 key), i see a blank window about 40 sec and then application begins to work.
    When i run it without debug (Ctrl+F5), blend starts immediately.

    Release or with debug info - the same.

    Step by step i found the following:
    the program run normal before calling HRESULT result = d3d11_createdeviceandswapchain() in a d3d_display_window_provider.cpp on line #232

    In any programs MVSE stumble with d3d11_createdeviceandswapchain(). Change of debugger type not work. Any help?

  2. #2
    ClanLib Developer
    Join Date
    May 2007


    Sounds like a race condition somewhere. Not sure where, I'm not familiar with clanD3D internals.

    If it is just the blend example that it happens to, maybe one of the settings the blend example is trying to use is either incorrect on ClanLib's side or your graphics card driver doesn't like it.

    It's unlikely to be your driver though, due to the simplistic nature of the example.

    Try updating it, just in case.

  3. #3
    Master Sorcerer
    Join Date
    Sep 2006


    The clanD3D internals are single threaded, so it can't be a race condition (in ClanLib code, at least).

    If it hangs for 30 seconds in D3D11CreateDeviceAndSwapChain then it is most likely display driver or OS related somehow. Alternatively it could be looking for debug symbols, but I think it caches those locally.

    With the June 2010 DirectX SDK I did experience some extremely long wait time with the D3DCompiler. That bug was triggered by compute shader compilation and was fixed with the newer D3D compiler DLL that came with the Windows 7 SDK.

    TL;DR; I have no idea why you are experiencing this.

  4. #4


    Apparently a problem with loading igd10umd64.dll - part of Intel Graphics Accelerator Drivers.
    I installed the latest drivers for notebook, and hence there is no solution. Thanks to all...)



Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts