Results 1 to 5 of 5

Thread: 3.0 LegacyGL build errors

  1. #1

    Default 3.0 LegacyGL build errors

    Having solved the Sounds/ problem, most of the build works but I get the following error:

    In file included from opengl_target_provider.cpp:40:0:
    GL1/GLX/gl1_window_provider_glx.h:39:35: fatal error: LegacyGL/opengl1_wrap.h: No such file or directory

  2. #2
    Master Sorcerer
    Join Date
    Sep 2006


    clanGL1 was shortly renamed to clanLegacyGL, and then afterwards it was moved into clanGL as a sub-target.

    Mostly this just means that the old clanGL1 files now belong to clanGL, and that the include paths needs to be updated.

  3. #3


    I've tried a strategy of replacing all instances of LegacyGL with GL1, and I added a GL1/precomp.h and GL1/precomp.cpp. For illustration see attached patch. Bear in mind it doesn't include the additions of precomp.h and precomp.cpp, as I don't know that they're actually helpful. I was hoping that various precomp.h might be magical files that would rectify problems on a clean build, but that's not the case. I don't really know or care how gcc utilizes precomp.h files at present, or if it even does. Just hackin'.

    I now get definition collisions:
    In file included from ./GL1/opengl1.h:35:0,
    from ./GL1/opengl1_wrap.h:34,
    from GL1/GLX/gl1_window_provider_glx.h:39,
    from opengl_target_provider.cpp:40:
    ./GL1/opengl1_defines.h:68:6: error: multiple definition of 'enum clan:isplayDefines'
    In file included from ../../Sources/API/GL/opengl.h:35:0,
    from ../../Sources/API/GL/opengl_wrap.h:35,
    from GL3/GLX/gl3_window_provider_glx.h:48,
    from opengl_target_provider.cpp:39:
    ../../Sources/API/GL/opengl_defines.h:84:6: error: previous definition here
    This is proving more tedious than the simple "rush to victory" I was hoping for, so assistance in the nature of the collisions would be welcome. I am fearing that the GL1-ification isn't complete, hence the collisions.
    Attached Files Attached Files

  4. #4
    Master Sorcerer
    Join Date
    Sep 2006


    Thanks for this patch.

    I've fixed the remaining compile and link errors in svn. I haven't actually tried launching any app based on it since the Linux box I got access to only got a SSH console.

  5. #5


    It builds! Testing to be done later.

Similar Threads

  1. Many errors in Android build ( RTBareBones )
    By mmortall in forum Proton SDK
    Replies: 5
    Last Post: 06-19-2011, 05:54 PM
  2. SetupOrtho errors
    By BigBMan in forum Proton SDK
    Replies: 6
    Last Post: 01-03-2011, 08:07 AM
  3. Replies: 3
    Last Post: 08-13-2010, 10:17 PM
  4. Windsock Errors
    By Tobin in forum Funeral Quest
    Replies: 4
    Last Post: 04-19-2003, 07:21 PM
  5. FQ errors
    By in forum Funeral Quest
    Replies: 3
    Last Post: 08-29-2002, 02:21 PM



Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts